Antimalware Service Executable High CPU Usage Solved for Windows 11/10

Originally published at: Antimalware Service Executable High CPU Usage Solved for Windows 11/10

Some Windows users report an issue where the primary Antimalware Service Executable (MsMpEng) unusually utilizes over 80% of the available CPU processing power, particularly on Windows 10 and 11. High CPU Usage by Antimalware Service Executable What is the Antimalware Service Executable (msmpeng.exe)? The Microsoft Malware Protection Engine, Msmpeng.exe, is the primary executable for the…

hey i tried this but it said not allowed

Thanks, I will give this scheduling thing a try.

Except that closing the process is not possible due to an “Access is denied” error as I’ve already pointed out. The only temporary solution appears to be a system reboot.

Yes, it is frustrating specially because it almost makes it impossible to carry on with your work while it is processed in the background due to the high resource usage. So until you find the time the temporary solution of just closing it is the best.

According to some reports, if you leave the process to be for some time and let the computer run it will automatically bring the usage back to normal and it won’t go up again. So I recommend giving that a go.

I 've tried all of the above, but still it runs. How can I Remove this shit

Non of these options worked for me using Firefox 61. However adding the Firefox FOLDER (from Program Files) to the Exclusion List found in the Virus & Threat Detection Section, then reloading browser, dropped my Defender CPU use to the usual 0.2%.

This didn’t help me at all. My screen looked nothing like the pictures after I clicked into task scheduler. I had no choices on the left to choose from. Did anyone else have this issue?

praise this article disk usage from 100 % to 3

How much RAM do you have in your PC? it is really hard to check what is the root cause of this issue we will have to take a closer look in your special case. Contact me on my Discord Zubyan Gul#9955

Thank you. :slight_smile:

Oh my gosh. It worked. This just started happening to me lately. I did the reschedule process you outlined.

True, it does. But I can’t wait that long if I’ve got work to be getting on with and it’s slowing down my computer as much as it does (i.e. so that it’s almost unusable - not just CPU time but disk usage scanning away). Simplest temporary solution is of course “switch it off and back on again” - i.e. save all work, reboot, start again - problem solved, until the next time it inevitably happens. But a bit of an incovenience all the same, and nowhere near “zero cost of ownership”, wouldn’t you agree?

Select “Windows Security” and then “Virus and Threat Protection”. Click on “Virus and Threat protection settings” and click on “Add or remove an exclusion”.

Despite trying all of these solutions, the antimalware executable still took over half my PC’s memory. I don’t know why none of it worked.

Try these steps:-

  1. Open the Windows Settings app.
  2. Head over to “Update & Security”.
  3. Open Window Security.
  4. Now click “Virus and Threat Protection” then click on “Virus and Threat Protection Settings”
  5. After that scroll all the way down till you find “Exclusions” after that you can follow the steps.

Amazing!! I disabled TrueColor and the CPU fan went silent!! Thank you very much for sharing!!

Oh my gosh. It worked. Thank you so much. Funny how this just started recently. I did the reschedule process.

You have to open these folders in the specific order. These folders should be on the left of the screen:
Library>Microsoft>Windows>Windows defender