BEST FIX: High CPU Usage By TiWorker.exe

Originally published at: BEST FIX: High CPU Usage By TiWorker.exe

“TiWorker is a WMI (Windows Modules Installer) Worker Process related to Windows Update. Usually, the error occurs after an update has run. In this fix, I will list five methods that you can use to attempt to stop TiWorker from consuming your CPU. If a process is utilizing the entire CPU or a portion of…

You can skip to Method 3.

Dude, you rock, thanks!

Thanks Kevin,
I had a problem with one of my laptops and when i followed Method #5 the problem was resolved. I had tried other registry repair software, but none was resolving the issue. :heart::heart::heart:

Hi windows …
this is one of your failures

go to MAC, they have one even better

good one… oops wrong photo, disqus seems awkward…

Thanks Kevin. I found info to run the system file checker awhile ago but no info on how to fix corrupt files – until I found your page. So I’ve run SFC again and got the message: “…found corrupt files but was unable to fix some of them…” I then entered the command: “Dism/Online/Cleanup-Image/RestoreHealth” as you suggested.
It completed the command (shows 100%), but now I get a new error message:
"Error: 0x800f081f
The source files could not be found. Use the “Source” option to specify the location of the files that are required to restore the feature. For more information on specificying a source location, see Configure a Windows Repair Source | Microsoft Learn
Any suggestions?

Perfect!!! I paid to geeksquad for fixing this and when they couldn’t I searched online and found this guide; happy to say that it was very easy to follow for a non techie like me.

Thank you

You cannot delete it if you do it might affect the stability of your system.

Yes go to Mac and they’ll tell you your 1 year old computer that you paid $5,000 for is out of date and that they won’t service it and that you should buy a new one.

how to delete it?

It works!


Can you install .NET Framework’s latest version and then see if you still get the error? Thanks

Thanks that was useful

I get this,“Error 87 The Cleanup-Image option is unknown”