Fix: 100% Disk Usage by System and Compressed Memory in Windows

Originally published at: Fix: 100% Disk Usage by System and Compressed Memory in Windows

High disk usage by the System and Compressed Memory process is often due to paging file misconfigurations, memory leaks in third-party software, or the Superfetch service in Windows. System and Compressed Memory 100% Disk Usage This process aims to compress the total size and usage of RAM and disk space on your computer. However, it…

Jay, I’ve been trying to solve this 100% disk usage problem for five months now, and your suggestion is the only one that has brought visible, instant results. Man, I’ve tried everything (except for replacing the HDD altogether) and read hundreds of articles and forums up to the point of obsessiveness. I don’t know why it’s only now that I’ve stumbled upon your answer. I’ve been visiting this particular article for, like, twelve times now.

Solving this problem has been a tedious and frustrating endeavor. I really hope that your answer put an end to this. I’ll observe for a couple more days, but so far, I can say that my PC works as if it’s new. Hell, it’s eerie how fast it is right now.

Thank you. I’d give a portion of my soul to you if only I knew how.

I did what Arne suggested. I also disable

  1. Window Superfetch
  2. Window Search
  3. Google Chrome preload page (similar to Window Superfetch but it is inside Chrome).
  4. Hard drive defrag
  5. Window indexing service
  6. Window update
  7. Microsoft update
  8. Get rid all preload app at start up.
    Set Antivirus to delay start.
    I did all things above, my window 8.1 disk usage went down like 5%. No more spinning hard drive when idling.

Have you done a cleanboot?

I’m still not sure what to do, the only solution that has worked for me has been to go into task manger and shuting down random processes under “local system”. Sometimes i hit the mark sometimes not, it’s extremely hard to pinpoint, but it’s very clear that there’s some garbage process that **** this all up.

I had this issue before but then it was simply disabling superfetch, that doesn’t work anymore after some self-installing piece of shit windows 10 update.

I tried to disable the system and compressed memory service but can’t access the task scheduler in the administrative tools.I use Windows 10 pro,please help

Jesus Christ what about telling us which service??

Jay, thanks for posting this, and Kevin thanks for taking the trouble to add Jay’s post to your helpful article. I came to threads on “System and Compressed Memory” because of researching high disk usage, HOWEVER–oddly–I have NEVER seen this process come up on my Win 10 Pro laptop (which is also upgraded–from Win 7). But you made me curious, and sure enough, when I check Task Scheduler, in my RunFullMemoryDiagnostic task (as well as ProcessMemoryDiagnosticEvents), the error message, “The operator or administrator has refused the request. (0x800710E0)” appeared. In fact, in my TS, the text is fully spelled out, not only the error code. Status is listed as Ready and the task shows as having run very recently in both cases. (Last Run Time) I then checked two other machines which were also upgraded, and I found that they also show the same (except in one case it says, as of 20 min. prior, “The process terminated unexpectedly (0x8007042B)”)

I thought from another comment that this is a service, but it also is NOT listed in Services. Under Actions it’s indicated as done by a “Custom Handler”. So perhaps this is not a Service at all but is handled by some built-in OS component called by this Task? In any case, why do I NEVER see it run in Task Manager on my system? I suspect this has never actually run on this machine, though I cannot be sure, as I haven’t seen it. But I do see just “System” run at the top of the TM list for Disk activity pushing the Disk to 99% for an extended period after resumption from Hibernation or Sleep.

Is there something I can do to make “System and Compressed Memory” run? It seems it should actually be a useful task, and should REDUCE disk access, not increase it. I seem not to be using it, unless it is part of “System” which does not show sub-tasks in TM. BTW, Disk use did lessen considerably on my machine after I restored control of Virtual Memory to Windows, as Kevin suggested. I had also disabled Superfetch previously, but I may restore that after seeing Virt. Mem effect.

If you run any form of encryption sfc and chkdsk will not work

In case this is useful to anyone, I’ve been plagued by this problem ever since upgrading to Windows 10, and I was ready to try option 3 above and disable the thing.

But when I got into the Task Scheduler, I noticed that the Last Run Result was 0x800710e0, which seemed suspicious to me. When I looked up this error, it turned out to be “The operator or administrator has refused the request.” Seems like some sort of access problem.

The task was set to run as “Administrators”, whatever that is. I’m on Windows 10 Pro, which was an upgrade from Windows 8.1 Pro, which was an upgrade from Windows 8 Home. So somewhere in its deep dark past, I had had the Home version. Not sure if that’s relevant…

When I went into each Memory task and changed the “use the following user account” to be my own (and I have administrator rights), suddenly the error codes went to 0 or 0x40010004 (which I haven’t found an identity for yet, but it doesn’t seem to be bad - at least it’s not an 0x8xxx HRESULT!), and my system is a whole lot happier. The system and compressed memory task is running in the background but using a more reasonable amount of system resources.

My theory: somehow in the Windows 10 upgrade process, that task got set up in a funky way, and the process kept thrashing with access errors. Now that it can do what it wants to do, peace has returned. :slight_smile:

Again, in case that helps anyone (especially if you wish to not disable the process and you can make it happy this way instead).

It is fixed. Thank you again.

No worries, as long as it’s fixed. :slight_smile:

Disabling Superfetch did nothing here.

Welcome. OR you can disable superfetch service as well.

Jesus Christ! What about just disabling the service? It works, believe me.

Kevin, thank you very much. It worked as a charm here. Disabling was the point.

Thank you for this; I’ve been trying to track down this issue for months. One of the first things I did was to manually adjust and set my page file, but that didn’t help. Later, I ended up disabling SuperFetch (which I suspect was the true culprit), but at the time it didn’t help. Now, finally, I’ve set my page file size back to automatic, and I’ve gone from ~4 cases of 100% disk usage per day to zero.

Thanks for the update.