FIX: AutoPlay Not Working on Windows

Originally published at: FIX: AutoPlay Not Working on Windows

AutoPlay is a feature that comes with all currently supported versions of the Windows Operating System. AutoPlay handles any and all storage drives that one may connect to their Windows computer, providing the user with a list of options every single time they plug a storage drive into their computer. However, Windows 10 users have…

The reg file will always trigger warning.
if you are not feeling safe with merging the reg file, edit the reg file to view the keys and manually update in the registry editor if you can.

I can’t get in the last part. What if I have already the name No drive type auto run? how to proceed?

I would love to post/publish issues on this site. However, since this is a blog (user-generated) posts are not an option. However, you can email me the titles on

Definitely NOT ‘best’ - this tweak has made me hopeful that there may be other tweaks waiting to be discovered. Solving the problem does not warrant the immense consequences of re-installing the O/S.

I have other issues I would like to put to this ‘website’, but although I have registered, I have found no way of starting a new thread - a hint would help.

Works for me thanks

Thank you! Trying it now…

The .reg file has security warnings, and the first fix did not work. :frowning: Anything else?

Didn’t work with the download. I give up, MS is a POS and it always will be.

This worked perfectly! I had to create the registry entry and when I finished and made the registry value 91 and rebooted; the system performed as expected! Thank you!!!

Changing the registry value data to 91 did the trick for me - finally my system now opens the USBs contents in Windows Explorer. However, the USB setting of NOT notifying me if there are issues connecting to USB devices is ignored. Upon USB insertion I get 'There’s a problem with this drive. Scan the drive now and fix it." When I click on that notification, a dialog box opens asking if I want to fix the USB. When I click on ‘Continue without scanning’, the contents finally appear. I have another Win10 system where the USB content display is IMMEDIATE upon insertion of the stick, so further improvement is possible - but how ? Specifically how can I enforce the setting of NOT notifying me about the USB state ?

Not sure, guess it would be best to reinstall Windows.