Fix: Cannot Access WD My Cloud Account on Windows 10

i did all the above but i still cannot access WD MyCloud on a windows 10 64bit desktop. It appears under Network in File Manager but does not allow me to access my files on the drive. Do you have further suggestions?

Tried options 1 and 2 with no luck. Tried Reimage and it also did nothing to remedy this. The My Cloud drive does show in windows explorer’s Network “folder” in the tree pane on the left side as a subfolder to Nework (my computer is listed as 1st subfolder, NASDRIVEEX2A is 2nd subfolder).

Clicking once on the NASDRIVEEX2A folder results in this pop-up error:

\NASDRIVEEX2A is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission.
The remote procedure call failed and did not execute.

Oddly enough, if I then click on NETWORK in the left pane (parrent folder to NASDRIVEEX2A), here is what I see in the right pane:

Computer (2)

[some other classifications of devices, printers, etc.]

Storage (1)

Is the extra info, “The remote procedure call failed and did not execute.” a clue as to where the problem may lie?

(note, I set this PC to Metered Service to halt windows updates, so I actually have 1510 right now and therefore I do not have a “reset network” option. My issues started after moving to a new house from a fiber modem to a cable modem; everything else worked A-OK but for some reason the change in (router/)modem has hosed my ability to map a drive to My Cloud NAS).

The first solution (using the Windows Credential) works perfectly for me! thank you so much!

thanks Kim, it will definately help others.

I had a similar problem on my 2TB WDMyCloud. All other Windows devices and Android phones had full access to the drive - but Win10 access stopped working (after one of those magic system updates).

I solved it using the following:
Go to: Settings > Network & Internet > Status

  • then select the “Network reset” link towards the bottom of the page
    It will do its thing and then it will reboot the PC. Once rebooted you will need to re-enter your WiFi password etc.

Please post back here if this helps…

this has actually worked!
great write up!

email on way

Hi Gordon,

I’d like to take a look at this remotely if you’re comfortable with it.

Please send me an email on


Hello Kevin - many thanks for your reply, I was away for a few days so didn’t see it.
The IP for my drive shows up as this is what I pinged, and it says that 4 packets were sent and received at 2ms. I can send you further info if you wish - screen prints etc…
The drive does not show up in ‘disk management’ tho?
Your help is much appreciated.

// indicates it was online, and now it’s not? see if you can ping the drive.

Hello Kevin - sorry to hijack this. I am having the same trouble as quintel. When I double click on the wd drive I keep getting an error message saying that windows cannot access //WDMYCLOUD. I have tried so many things including factory resets etc. If you are able to help it would be very much appreciated. Rgds

Thanks K.arrows for sharing this very good information. Got fix mine with first method.

so when you double click on the drive, what does it says or does?