Fix: Cannot Access WD My Cloud Account on Windows 10

Originally published at: Fix: Cannot Access WD My Cloud Account on Windows 10

WD My Cloud is one of the best cloud storage services out there, and since the service has so many users, there have been countless Windows 10 users complaining of not being able to access their WD My Cloud accounts ever since their upgrade to Windows 10. The problem has become so severe that some…

Had a problem a while ago where one laptop couldn’t connect to my WD My Cloud EX2 Ultra which was solved by adding Windows Credentials as in Method 1. Following the latest updates I lost access again, the Windows trouble shooter said my network was configured correctly but the device wasn’t responding. Following this post I tried Method 2, the registry edit, that made no difference but Method 3, network reset solved it. Thank you so much for these instructions, they’ve really helped me out :slight_smile:

So, after spending the last three days trying to get back into my mycloud after a windows update, i used the credentials manager method fix above and it’s all good now, many thanks

Go into this address: HKLMSYSTEMCurrentControlSetControlNetworkProviderOrder
Click on the provider order entry and change the order to accommodate WDMyCloud first. Save your settings and check if it helps.
Also, make sure that you have never disabled any windows service to increase performance because there are certain services that users disable in order to increase performance and in return this functionality is disturbed

And if I am not the admin?
Other people in the owncloud of an organization should be able to use/sync the desktop app…

Many thanks, this (#1) allowed me access again.

Hi, I’m having the same issue as with Gordon. Any news on how was it solved?

#1 worked for me perfectly. Thankyou for this helpful post

Good article. There are various levels of issues with local network. I run into host names not resolving to IP’s on my LAN on occasions. I can assess everything using IP’s. It effect only single local computer not resolving IP’s. It comes and goes and it is related to network adapters and drivers. I got this issue again on my USB -> LAN adapters. It works with WiFi. I’m tempted to do network reset.

Method #1 worked brilliantly! Thank you VERY much!

Method 1 worked for me, but I just wanted to let people know that they have to make sure they enter the username and password for the admin. I had another account for myself, and I was entering that one and wasn’t working. It worked when I entered the admin one. Thanks so much for this! I spent 3 hours trying to figure this out.

I had success with option #3 with one adjustment. After resetting the network and restarting the computer, the network folder was empty. I had to restart my modem for the WD Cloud to see me. Once I did that, everything came back on. The solution was easy. Getting there was a Bi***. Thank you for the ease you showed the steps.

Did the Network Reset and now it all SWEET! I can access my WD MYCLOUD and it’s snappy! Been a long time since it was working so well! Thanks!

success w option #1. THANK YOU SO MUCH FOR POSTING THIS!!!

my problem is a little different - the lights on the back say its connected to the router, router says there is something connected onthat port or any port i plug it into, but can not see it in the active devices on the router or on my win 10 laptop fully updated. need some files and cant get them!!

Thanks, i have now added method 3 as the network reset method.

Thank you for the update.

What exactly did you reset, can you list the steps or provide a screen shot so we can update this guide.

See post below, by Kim Rowden. It’s a Win10 built-in function. You need the latest version of Win10 (anniverdary or creators) to even see the reset option.

Added the entire LAN to the dmz, made no difference. Got tired of messing with it last night so I bit the bullet, turned off “Metered Service” and went though 14 hours of Windows Updates attempts, errors, fixes, reconfigurations, reinstallations. After getting Creators edition stable (and still no resolution for the WD mapping problem) I did a RESET on my network. 2 hours later I had my WD mapping working again. So it seems the RESET works, but you gotta have a recent edition of Win10 to find the RESET option in the first place.

can you add nas ip to dmz?

Sent from my Samsung Galaxy smartphone.

-------- Original message --------