Fix: "Cannot Rip One or More Tracks From the CD" WMP

Originally published at: Fix: "Cannot Rip One or More Tracks From the CD" WMP

Several Windows users are reporting that they are prevented from ripping music with Windows Media Player by the “Windows Media Player cannot rip one or more tracks from the CD” error. Most affected users report that the issue occurs when they try to rip an Audio CD. “Cannot Rip One or More Tracks From the…

I needed to set up the Music Library. Thanks! Because Windows 11 (and even 10) don’t even show Libraries by default, I had forgotten all about them. As soon as I added a folder to the Music Library, the rip worked perfectly. That error message was a misdirection.

Thanks, changing the library settings fixed the issue for me.

I have been transferring my cd collection to mp3, but suddenly track one has a red cross on it and when i try to rip from track two the disc ejects. Why this should start now god only knows. No 1 worked and has stopped me from bashing this laptop to bits! Thank you so much. Knowledge is power - and you have it.

Thank you so much!

Brilliant. Fixed my wmp issue. I had no music location listed… I suspect this is because I was moving stuff to point to OneDrive…

Thank you so much for these tips.
This was driving me crazy!!
I had inadvertently changed the folder I used to use and that’s what was confusing WMP.
So No. 3 helped here.