Fix: High CPU Usage by Service Host: Local System (Network Restricted)

I have the y510p and I ended up getting it figured out, it didn’t like that sd card that was in it at the time, pulled that out and it fired right up

So, change the NDU->start to 4 and went to restart and now the puter is hung up on the Lenovo screen.

another quick way to fix… Reset the Windows Defender Firewall to the default settings.

To do this open
Settings -> Update and Security -> Windows Defender -> Open Windows Defender Security Center -> Firewall and Network Protection -> Restore Firewall default settings

This seems weird. After step 4, won’t the system shut down, and How will you monitor. On Re-starting, it will be the same. Correct me, if I am wrong.
Also, using solution 3 did not work for me, as the system checker was not able to start.

Good stuff here. Thanks

Thanks, good stuff here

when I do abandon unsaved data and shutdown,the service host windows event log and many other services come up,and then again service host local system starts.Not helping.

My problem was caused by external usb audio interface, system host raised my cpu usage to 95%. After updating drivers the problem disappeared.

What did you do to reduce the disk usage?


Its safe just to disable the superfetch?

Just use the instructions (manual) that should help.

Is there a free program?