Fix: Realtek HD Audio Manager Headphones and Speakers Show Up as Same Device

Originally published at: Fix: Realtek HD Audio Manager Headphones and Speakers Show Up as Same Device

If you are using headphones and speakers then you might experience this problem. A lot of us want to connect both our headphones as well as speakers to the system so that we can hear the music from whichever device we want i.e. speakers or headphones. The problem here is, if you are using the…

There is no more ‘Realtek HD Audio Manager’ anymore since (driver package) R2.82. There is an alternative though; you can use the ‘Realtek Audio Control aka Realtek Audio Console’ app from the MS store. The settings are (still) a bit weird though and counter intuitive. Under ‘Device advanced settings’ you have to turn ON “disable frontpanel detection” and you also have to ENABLE “Mute internal output device, when an external headphone is plugged in”.

Few years behind but thanks so much for this article! Why the RealTek application wouldn’t default all audio ports to different output devices simultaneously is beyond me.

Changing the bios setting and uninstall the driver definitely works for me, thanks!

Some users have a “Device Advanced Settings” Option. Look to see if there is an application called “Realtek Audio Console” Installed on your computer

Go into device manager, click on “View” and select “Show Hidden Devices”

Top right corner there is a gearwheel icon, click and get in “option”. That’s the advance setting for new version. You can see the option “Make front and rear output devices playback two different audio streams” there.

i have a different realtek menu with no “advanced” option
in the gear icon there notihng about the playback device…

Have you selected “Speakers” from the top? if you have and there aren’t Advanced Settings make sure that you have installed the latest version of the drivers

This fixed my problem, thank you so much mate.

Thank you for your feedback!