FIX: Repair Corrupt Opencl.dll in Windows 10

Originally published at: FIX: Repair Corrupt Opencl.dll in Windows 10

After updating to Windows 10 Update 1511 – better known as the Windows 10 November Update or Threshold 2 – that was rolled out late last year, lots of people started complaining about a file named opencl.dll becoming corrupt. Upon further investigation and a lot of squabbling over Windows 10 forums, it was discovered that…

thank you very much, I work !!!
this problem I was **** many days ago, towards my pc had 100% hard drive, did not shut down the pc verywell and froze for many time, and sfr /scannow cant repair the file , now the problem has been fixed and everything goes back to normal, thanks a very much

run the following command : Dism /Online /Cleanup-Image /RestoreHealth
and then do sfc /scannow

Actually when I run the SFC /scannow command it turns out clean (no integrity violations found). However when I check the CBS log this entries are present:

CSI 00004250 Hashes for file member SystemRootWinSxSwow64_microsoft-windows-r…xwddmdriver-wow64-c_31bf3856ad364e35_10.0.10240.16384_none_b928dea146e73395opencl.dll do not match actual file [l:20{10}]“opencl.dll” :

CSI 00004251 [SR] Cannot repair member file [l:20{10}]“opencl.dll” of microsoft-windows-RemoteFX-clientVM-RemoteFXWDDMDriver-WOW64-C, Version = 10.0.10240.16384, pA Host= amd64 Guest= x86, nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35} in the store, hash mismatch

The DISM log on the other hand does not contain any repair failed entries.
So is the file corrupt or not eventually?
Thanks in advance!

I was leery running this fix because of the message that it will be transmitting my files to some server. I pressed ctrl+z key combo to interrupt the execution but it ran anyway. However, after sfcfix finished I re-ran SFC /scannow and it ran clean. So I suppose the fix works. Thanks and hopefully this tool is useful to others also.

Worked for me too. My laptop was hibernating at 30% power with battery turning to 0%. I thought the battery was weak. After applying this fix laptop’s power plan is working correctly. I guess the corrupt file was messing with my graphics power. Well Thanks bro

so options 1 worked.

This fix worked for me. Other fixes in forums were not successful.

:WindowsLogsCBS>sfc /scannow

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.

Verification 100% complete.

Windows Resource Protection did not find any integrity violations.