FIX: Screen Goes to Sleep/Off By Itself on Windows

Originally published at: FIX: Screen Goes to Sleep/Off By Itself on Windows

Some Users reported monitor or screen going to sleep or turning off by itself while watching a movie, playing video games or doing nothing. This usually happens after a couple of minutes. Most computer screens nowadays are able to save energy by dimming down the back light of the screen itself to a lower percentage, or by…

Press “Windows + I” and click on the “Find a Setting” search bar. Search for “Screen Saver” and click on the “Turn Screen Saver on or Off” option. If “none” is selected as the screen saver, select something else and change the wait time to 10 or 15. Apply your changes and restart the computer. Now again go to the Screen Saver settings and disable the screen saver without changing the wait time setting and check to see if the issue persists.

Please send me an email on so i can take a look at this issue remotely.

Scratching my head as it keeps my screen blank randomly, reinstalled Windows 10, still does the same thing, Last thing i did, opened up my PC case and so far its been stable.

I think the problem is with HDR monitors in windows 10

My specs:
Intel core i7 7700k
GeForce GTX 1070
16gb ram 2133mhz
m.2 SSD SAMSUNG 980 1tb

Window 10 is suck

I think the problem is with HDR monitors in windows 10

and it’s still turning off after like 30 seconds when not in use. I’m not sure what’s going on. My monitor doesn’t even have a menu in it. So there’s nothing to check anymore.

I am running Windows Pro build 19041.746. To change your power off/sleep time go to settings/ system/ power and sleep and then adjust the time that you want the system to wait before going to sleep or turn off. You can also choose never. This is a slight alternative to the one shown in the article.

Awesome, you make my day !

it works for me, thanks you very much!!!

Were you able to fix it? My machine constantly shuts the screen off, which shuts my streaming music off, or rather, it lowers the volume and puts into mono or something strange. I can’t figure it out. My tv screen saver is off, so, it’s not doing it. Just curious.

Did you find the problem? Having the same issue.

It doesn’t work!

So I’ve gone through all your steps, SFC scan did not find anything and the problem still exists. Monitor goes to sleep after fifteen minutes.

Here are my system specifications:

Windows 10
Intel Core i7-4790 CPU @ 3.6 GHz
GeForce GTX 970

All drivers are up to date. Hope you can help me out, I would greatly appreciate it!

Peter-Jan de Vries