Fix: Security database on the server does not have a computer

Originally published at: Fix: Security database on the server does not have a computer

This specific error appears when a user attempts to log in to a domain. This can be quite problematic because there doesn’t seem to be a way to circumvent this. The error appeared on various versions of Windows OS but it appears most commonly on Windows 10. The Security Database on the Server does not…

I had the same question. None of these suggestions solved my problem. I had to:
1) Remove the workstation from the domain
2) Delete the Computer from AD Users and Computers
3) Add the Computer to AD Users and Computers
4) Rejoin the workstation to the domain

When you log into the workstation as a domain user, it will run through the “Hi…This might take several minutes” dialog boxes.

worked well, thanks. I have removed the internet cable and I was able to log in. Many thanks, legend!

I can even log in to the computer/server
how can I configure the time?

Fixed and resolved: You need to remove from DOMAIN controller to WORKGROUP and Reboot it. Rejoin to your DOMAIN Controller and reboot it. You can login with your AD credentials americauser.

remove the network cable, log in the plug the network cable back. (will work if you logged in previously)

Try setting the date and time through Bios.