Fix: Unable to terminate process 'Access is denied'

Originally published at: Fix: Unable to terminate process 'Access is denied'

This problem happens with users who tries to terminate a process from the Task Manager. Once you select the process and click the End Task button, you will see an error message telling you that the operation could not be completed. Most of the users who faced this issue had problems with running games or…

man avast is just really having an affair with my disk it uses over 200mbps
and i tried with process hacker to end the process but it still doesent want to end it

most useful Method 5: Use WMIC


i’d suggest not installing it again, windows defender is good enough.

What’s the name of this program?

i had a program that was not part of windows, not a virus, running as admin and not as System and i launched a cmd as NT Authority/System and tried both taskkill and wmic call terminate and it wouldn’t die. what was going on???

It really depends on the program you are trying to shut down if it’s official Microsoft Windows program and it’s essential for Windows to function properly you won’t be able to close it because these programs have ‘SYSTEM’ permission which is higher than Administrator.

Despite using CMD as administrator, the program I tried to shut down still said “Acess Denied” I am a little puzzled, I was not aware that a program could deny CMD in any way shape or form? Especially not if run as an admin?

In that case, your best bet would be to just uninstall Avast and reinstall it again.

processhacker cant not handle it XD(i mean my firefox.exe does not end task)