Fix: Windows 10 Loses Internet Connection

Originally published at: Fix: Windows 10 Loses Internet Connection

After the launch of Windows 10, a majority of Windows users began shifting their operating systems to the latest version. Users have reported losing internet connection after installing Windows 10. This is quite interesting, as Windows 10 is the successor of all previous Windows versions and should be the best of all. We know that…

Interesting, I think I can try to resolve your issue. However, I think you might have tried it already I can still suggest something so it might help someone else having this issue. I think disabling the fast startup should fix this issue for you because fast startup doesn’t allow some services and drivers to restart correctly and as you mentioned power-cycling the PC fixed your issue so this has the potential to fix your issue as well. Here are the steps:-

  1. Press Windows + R key, this should open the Run program. Now type “powercfg.cpl”.
  2. On the left pane, click on the option called “Choose what the power buttons do”.
  3. Now click on the option on top “Change settings that are currently unavailable”.
  4. Now make sure the option called “Turn on Fast Startup (Recommended)” is not checked, if it is then simply uncheck it and restart your computer properly.

Hope this helps!

Do a system restore to an earlier point in time when it was working. see steps here: How to: Configure System Restore In Windows 10

I Do have one other nagging issue; have not been able to isolate it or reproduce it. In the recording studio I use USB3.0 to connect to a pro audio PreSonus 192 8-16 channel DAC, and also use a PreSonus Audio Box 96 for desktop speakers, I do not use the on-board audio. Lately over the last month or two, I get spurious dialog box popup when I’m using the USB to audio devices… just realized it is happening to both PreSonus DACs. This dialog only comes up when I’m playing something thru VLC or thru my DAW (my case is Cakewalk); when either is running (or both) I’ll see what seems to be a ‘Audio channel profiler’ that is going thru all audio channels and testing what are the available bit-depths and sampling rates. It will sometimes happen while playback in the DAW and occasionally during REC (totally not good !) I’ve connected each of them to the USB3.0 PCie buss, as well as the back of MoBo USB3.0 ports. Still get this issue. But, what is even weirder, if I start the DAW, then load a project, I’ll see the dialog come up often and randomly for the first while, then afterwards I see it less, but ocassionally will pop up… for example my DAW has been running (background) for about 3 days. I have NOT seen any ‘reprofiling’ dialog boxes… seems to happen during the startup and after project load… does not make sense.

Could it really be time to build another system with a new motherboard? Any ideas would be awesome… thanks so much for your attention…
you’re gold.

Byl S.

good morning i,m a little lost as far what commands to type in are they the one,s nctsh windstock reset catalog or resetting global ok.?

Method #1 worked like a charm. Thank you! Can’t believe Microsoft would do such a poor job on updates going out to every windows user that make windows 10 machines go completely dark for networking. Was such a frustration until I found your solution. Next time I’ll buy a MAC.

Your welcome! Please keep me updated.

That setting is not set, we disabled that a while ago. (Turn on Fast Startup) is not checked. I’ll keep you posted if I find something else.
thank you very much for such a quick reply… you’re gold

I’ve had this problem for a few weeks now… not a clue why. I stumbled on to something else that worked. I just loaded the latest Win10 update. (2022.5x may, 2022 update); previous updates had the same outcome; internet lost after reboot… I am suspect of my motherboard, however the solution that worked for me is this:

First completely shut down the computer, I mean all the way down to off. Then flip the power switch on the back of the PC, then unplug the power cord… On some computers, you’ll hear a very slight click; it’s a capacitor discharge on the power circuit on the mother board (where the surge suppression happens on startup. I leave it unplugged until I hear that click, or wait about 10 seconds. Then re-plug in the power cord, flip the on switch on the Power Supply, then boot your system.

One of the first messages you will see after it’s up and you’re logged in, on the right hand side of the monitor you’ll see a curious system message saying “Do you want to allow computers on your network to recognize you?” say YES, and within a minute, you’ll be able to fire up a browser and go somewhere successfully, but note, the little GLOBE you see where the internet icon is in the right side of the task-bar, will not convert from Globe to I-Net icon… but as soon as I loaded up a website, and success, I’ll see the globe change to the inet icon.

Everything works. My guess is, it may be partially my own issue, I’m running an early generation Ryzen AM4 motherboard, for about 3 years, and it’s been in two different computer cases during this time. It’s quiet probably that the motherboard (and the Intel Network chip may have started to fail. It happens at every reboot these days… Pain in the arse being frustrated with the reboots for weeks now, but this solution is working for me… I’d suggest if you have this issue, give this a try and see if it works. In the next coming week I’m building a full Ryzen 9 system with 128GB of Ram, and two larger SSD cards for storage. I will note whether this issue reoccurs on the new system. (there will be a clean OS… not 11, (I don’t update OS’s until at least 18 months after release, my experience with microsoft is they always put products out before the full beta test is completed, and lots of bugs and mistakes are found; I run a system in a recording studio, I cannot allow my business to be halted because Microsoft got careless (They should leave the OS market and make Linux is only kernel, with their gui (or any other) and run all windows software in direct mode, not interpreted… (this is my wish…oh well) best luck… nothing is more frustrating that spending hours figuring out why windose is failing to do it’s basic stuff… connect to everything. Thanks folks.

Method #1 works for me, but I have to keep resetting Winsock every few hours! It’s tedious and inconvenient. Why is this happening? How can Winsock get corrupted every few hours? Please help!

Method #1 worked like a charm for me with the first line command “netsh winsock reset catalog” only and after rebooting . Thank you! Is it recommend to enter the two flwg commands anyway?

I have a Dell desktop and also get this message.
My solution has been to disconnect the Router ( Belkin N300 Ethernet Connection), reconnect it and reboot the computer and it works every time.
I am not a computer expert and am appalled that Windows have put out software that has this common fault. We users are not all computer buffs, nor do we want to have to fiddle around with computer settings.
Microsoft should sort this out - it is their software.

Follow steps in the listed order.

Lost my internet after a windows update. Method #1 above worked great and it was really easy. Thanks!

I downloaded Windows 10 on to my computer last weekend was very sorry I did it I lost internet called Microsoft Windows they wanted $200 to correct the situation anyways I tried method number one and it worked thank you so very much.

Thanks! Works perfectly

Window 10 security update yesterday…no problems previously. We have Internet…problem states network protocols are missing, Windows sockets registry is missing???