FIX: Windows 10 update stuck at 32%

Kind of defeats the purpose of an upgrade doesn’t it? Why not just format and do a fresh install.

Several hours each time, one started before going to bed at night, still at 32% in the morning, another before I left for work so I was gone for over 9 hours. So on average I would say between 5 - 9 hours each time.

for how long have you the system running during install?

I’ve tried everything I could find online to resolve the ‘stuck at 32%’ issue. All of the above suggestions didn’t work, updating drivers manually, using ISO to install and choosing not to update drivers, still no dice. After 8 attempts and countless hours of troubleshooting I can’t get past 32% and getting zero help from MS.

What external devices are connected and which anti virus are you using?


After it restarts do I turn the internet back on ?

run command prompt as admin

Every time I entered a command it would say “access denied”

You will need to use another computer to do this. Windows 10 iso can be downloaded using Windows Media Creation tool; and Windows 10 USB can be created by writing the downloaded iso to usb using Rufus. If you have an advanced option on screen, you can go to the troubleshoot menu to reset.

How can I create a windows 10 usb media since windows 10 is not yet installed?

There is from hdwwiz.cpl but do not uninstall/delete them. They are supposed to be automatically upgraded. However, try disabling wi-fi, ethernet and perform method 2/3.

I cannot find any pnpclean.dll in Windows7. Is there a way to clean the driver packages from my Windows 7 system before I start the installation?

They work on Windows 7 too.

Do you have any suggestions that will work with Windows 7? Suggestions above seem more geared towards windows 8 (even things like pnpclean.dll only exist in 8). I have a HP dv5t-1000, no usb devices plugged and window update itself has no problems, yet no matter what I have tried such as the suggestions above and even manually updating every possible driver in advance of the upgrade - nothing has worked.