Fix: Windows firewall can't change settings error 0x80070422

Originally published at: Fix: Windows firewall can't change settings error 0x80070422

Errors are quite common in operating systems, whether it is Windows or OS X. These errors cause some problems for the users. Some of these errors have easy fixes, while others require a lot of effort. Some users have reported an issue related to the firewall within Windows. According to them, they receive an error…

Thank you so much. I was afraid that I might not be able to turn on my defender again.

God bless you bro <3

Helped me to get mine running as well, Thanks. please help me

u’re a genius man! thans a lot!

Method #1 was all it took to fix the problem for me. Very clear and concise instructions. Thank you very much for these solutions.

I have the same issue, but it’s on windows server 2012…
Have tried the above steps but the problem is still existing…

Thanks in advance.

Thank you for instruct and help me please

Superb, fixed my issues. Many thanks help me start click and pictures problem


You still can’t change the Start, Stop, Pause, and Resume settings as those settings Windows does not want you to change in this^ way anymore. But, this means your Windows Defender Firewall services are off.

• Press (Windows + R) and type in “regedit” and press enter.
• Go to: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesMpsSvc
• Right click and [Modify] the “Start” entry.
• Change the value under Value to: (2 = service on) and (4 = service off).
• Now you should be able to enable to Windows Defender Firewall under (Start>Settings>Update & Security>Windows Security>Firewall & network protection)

Put it in safe mode and check if it works.

New updates disable some of these options and prevent the user from changing them. You should reset the computer to an earlier date where this option wasn’t disabled.

First method worked for me! Thank you for the article.

this is absolutely the easiest way. Thx Mr.Arrows :slight_smile:
Your problem solve is better than this

It works.

Didn’t help