FIX: Windows Shell Common DLL has stopped working

Originally published at: FIX: Windows Shell Common DLL has stopped working

A DLL file contains data and sets of functions that other programs in Windows use on a daily basis. For example the dialog boxes that you interact with in Windows use various functions from the Comdlg32 DLL file. Every process in Windows depends on a DLL(s) one way or the other. The Windows Shell Common…

You’re Welcome. Thanks for getting back to me

Unfortunately not. There have only ever been one set of drivers: v1.0 which I am already running.
Something definitely changed when I switched to Windows 10, because it was working fine before that.

It is definitely the drivers. The latest drivers could be a problem, can you rolling back to a previous driver?

I have tried all of the above in the past, none of which have helped to fix the issue.
Nevertheless I’ve followed your guide as closely as I can again, and again, to no avail.
Every time I try to change recording settings I get the error. It doesn’t matter if I left/right-click or try to change anything at all, the DLL crashes.

Please help, I am at my wits’ end.

I am having a situation where I can’t get my sound to work, and once or twice this came up Windows Shell Common dll is not responding. can you give me some more information as to how to fix this situation. it would be greatly appreciated.

Kevin Hi, I just wanted to send you a quick message.
Firstly, sorry I didn’t get back to you earlier, life got busy.

Secondly, this issue has somehow magically seemed to resolve itself. I know I’ve had a couple of updates installed by Windows in the last month or so, and I suspect a fix has been implemented.

Again, I can’t say exactly what or how, I just know it works now and I’m no longer experiencing the DLL error.

Thanks for your efforts nonetheless.

sent you an email.

Please do a repair install. (search this site for) repair install windows 10.

Please open Powershell and type the following:
Set-ExecutionPolicy -ExecutionPolicy Unrestricted -Scope CurrentUser
press enter, reboot the pc and then test.