Fix: Windows Updates Error 0x8024401c

Originally published at: Fix: Windows Updates Error 0x8024401c

When the Windows 10 Technical Preview was launched for the whole world to test and assess, users were finding issues, bugs and problems left and right. One of the many issues that Windows 10 Technical Preview users bumped into was their computer not being able to download and install Windows Updates because of error 0x8024401c.…

No, it wont since the GP is in effect. assumption i never tested it in a domain environment.

Can you elaborate? what are you facing an issue with?

Thank You!!!

Hey help me please. I don’t have UseWUServer in directory what should I do?

Hi Kevin,

Does it not by pass the Internal Wsus server and download the updates from Microsoft if used in a domain?

This worked for me, thanks.

Yes. it’s working! Thanks!

The fix seems to have worked for me. I set the Registry setting to 0 and the updates started. Thank you

The windows update option is not available in the registery

hey the process u have mentioned in the process of edit registery is not working in windows windows update is not working

It does. This key determines the source of updates and switches it to Microsoft… When I switch it back to WSUS it fails again.


It’s a little bit late, but maybe someone is still searching for a solution.

I got this error on several Windows Server 2016 machines, but not on Windows 10 at all.

WSUS (Upstream) is running on Server 2012R2 (4 cores, 16GB RAM) and Downstream Servers are 2008r2 and 2012r2.

All WSUS Servers are patched with the latest updates.

I tried a lot of stuff which I found on the internet but nothing really worked for me.

I found a third party script from Adminj to fix the problem!

!!Use it at your own risk and create a DB backup before you run it!!

!!Also open the ps1 script in ISE or another editor and read the instructions and prerequisites carefully, before you fire it up!!

In my case i used ./WSUS-Clean.ps1 -firstrun

After the script finished I used ./WSUS-Clean.ps1 -DirtyDatabaseCheck to repair the SUS DB.

I also changed some values of the WSUS ApplicationPool in IIS (Advanced Settings).

Queue Length: 25000 from 10000
Limit Interval (minutes): 15 from 5
“Service Unavailable” Response: TcpLevel from HttpLevel
(Optional) Private Memory Limit (KB): 0 from 18342456
I hope this helps someone who is still struggling with this error.

Best Regards,

Unknown Admin

Worked here as well, but what if I want my users to get their updates from my WSUS server?

Thanks. It also worked for me