Fix: WMI Provider Host (WmiPrvSE.exe) High CPU Usage On Windows 10

Originally published at: Fix: WMI Provider Host (WmiPrvSE.exe) High CPU Usage On Windows 10

WMI Provider Host WmiPrvSE is a Windows Host Management Process that is used by the Developers for Monitoring Purposes. WMI Provider High CPU Usage This behavior is usually seen on Production Environment After upgrading Windows 7 to 10 many of the users have noticed spike in CPU usage which makes the system lag, hot and…

Should I wait for WMI to start acting up to do this? Because I did this while my computer wasn’t using much CPU, and I couldn’t find the PID it showed me.

One of the errors I got was the LanmanServer. But I believe I’m not supposed to uninstall or stop that. Windows 10 here

thank you for letting me know.

when you try to stop wmi service it will warn about the dependent services. those are the potential culprits. in my case it was hp software framework. uninstalling it solved the problem

make a bat file and open it everytime you boot your pc
or make an autoexec to open it manualy

Is this on Windows 10?

When you’re not seeing the ID is it still eating up cpu? Try the steps listed here: How to: Disable Telemetry in Windows 10

absolutely a great fix. 2 bloat software packages (HP) creating the errors in WMI. disabling these two (one being HP wireless assistant) fixed the issue. CPU clocking at 12% as compared to 92%. Windows 10 is handling the wireless function on my HP Compaq just fine. Never found data on 2nd program, but it certainly hasn’t been missed.

I’m reading multiple errors with multiple different clientprocessid’s. When I loooked up the first process id found under services there are multiple services sharing the same id #. Not sure about where to go from here.

From the services.msc menu, disable the service. Reboot and test.

Did the above but sadly the WMI provider host is still running at 30 -40%. The laptop is an hp cq presario and it had the problem with windows 8 and I upgraded to 10 in the hope all would be cured. If you have any answers I’d love to hear them

It is WMIPRVSE. I’ll try a clean boot

Is it the WMIPRVSE consuming the CPU? Hold Ctrl + Alt + DEL keys together to go to task manager; click the processes tab an then click processes once to list the processes. Try this: How to: Clean Boot Windows 8/8.1/10

I’m still getting high usage. This only started after Windows 10 was installed.

Try this: How to: Clean Boot Windows 8/8.1/10

Any updates on this?

I have lots of error in the Operational list, but I can’t find anyone matching in the task bar

Reboot PC and rename the process to something like

Hi Kevin, I’m having this problem too. I have follwed your excellent steps and found the culprit to be a HP Software Framework Service so I stopped the service and uninstalled the program however it then moved to another HP service so I removed that one. The PID of the offending process is now claiming to be that of one of the HP services that I have already removed. Any ideas?