Fix: Your PC or mobile device doesn't support Miracast

Originally published at: Fix: Your PC or mobile device doesn't support Miracast

Some users have been encountering the “Your PC or mobile device doesn’t support Miracast, so it can’t project wirelessly” error when trying to connect through a Microsoft Wireless Display adapter using Miracast. Most affected users report that this error occurs even after they’ve made sure that they meet all the requirements to run Miracast. The…

We will have to check if the Miracast isn’t supported by the Network driver or Graphics Driver. Please let me know the results of Method 1. So that we can proceed.

If that’s the case I think the Windows Update is actually trying to change something with the driver but it fails so it resets your driver. I assume you are having a laptop but this method should work for both computers and laptops, try this out.

First of all, if you are using a laptop I suggest you download the Intel Dual Band driver provided on the Official Product Support page for your laptop, as those drivers tend to be better, stable, and overall more optimized for your laptop. Once you do that or you aren’t using a laptop but you are on the computer you will have to stop Windows Update from changing the driver parameters or even try to update it. Follow these steps:-

  1. Click on the Search bar then search for “Command Prompt”, Once you find it click on “Run as administrator”.
  2. Once that’s done type the following commands one by one and press enter:-

reg add “HKLMSoftwareMicrosoftPolicyManagercurrentdeviceUpdate” /v “ExcludeWUDriversInQualityUpdate” /t REG_DWORD /d “1” /f
reg add “HKLMSoftwareMicrosoftPolicyManagerdefaultdeviceUpdate” /v “ExcludeWUDriversInQualityUpdate” /t REG_DWORD /d “1” /f
reg add “HKLMSoftwareMicrosoftWindowsUpdateUXSettings” /v “ExcludeWUDriversInQualityUpdate” /t REG_DWORD /d “1” /f
reg add “HKLMSoftwarePoliciesMicrosoftWindowsWindowsUpdate” /v “ExcludeWUDriversInQualityUpdate” /t REG_DWORD /d “1” /f

  1. Once you do that restart your computer. Now Check to see if the issue persists.

Thanks for your help. It seems everytime Widows 10 does an update, I have to fix this using a variant of Method 4. My Wireless adapter is an Intel Dual Band Wireless-AC 8260. Under the advanced tab, I have to select Prorerty: Prefered Band, Value: Prefer 2.4GHz. Just throwing it out there for People who read comments.

I succeeded connecting at the end but its very laggy to project any game. It’s either my connection speed or because my pc is like 10 meters away from the TV. Sometimes it connects and sometimes still fails. Anyway thanks a lot for you being so kind to help me!

This seems like a firewall issue please try method number 1 from this article:-

If that doesn’t work for you try this:-

(If you have any 3rd party Firewall please disable it to test)

  1. Press the “Windows + I” key together to open the Settings app.
  2. Once the settings are opened navigate to “Update & Security” and then open “Windows Security”.
  3. Now head over to the “Windows Firewall” section and Set “Disable Domain, Private and Public Network” to off.
  4. Try connecting to your TV again if it’s connected set Windows Firewall on again.

Yes, it is okay if the network adapter is connected through USB. Also, you have to connect through WiFi.

Hello there!2 questions.
1st Is it okay if the wireless network adapter is not connected directly to the motherboard but through usb?
2nd Do I have to connect to the internet through the wi-fi or I can connect through ethernet as long as I have a wireless adapter connected? Thanks!

Thanks for the Article. It was really helpful.

  1. In my case Method 6 worked. All other were showing okay or latest version or support. However disabling the driver and then enabling it solved my problem.

Thanks a lot for your reply! I checked through the first method, display driver model is 2.0, and if I check the DxDiag in notepad it says “Miracast: Available, no HDCP” .

Wireless Network adapter is needed for it to work, you can just buy a network adapter card online and use it to connect your PC to the network wirelessly. Also, check through the first method if your computer supports Miracast.