How to Disable Task View on Windows 10

Originally published at: How to Disable Task View on Windows 10

With the release of Windows 10, Microsoft introduced virtual desktops that allow users to operate multiple desktops on one screen. Using the Task View feature, users are able to see all currently open applications, as well as all desktops that are open. Users who do not want to use this feature have options available. It…

It might have been a temporary glitch, you can either downgrade to the previous version of Windows or you can try to check for updates to a different version or to acquire a patch for the fix that Microsoft might have released

Thank you for sharing your experience

hopefully I am not jumping the gun in celebrating having found a fix for this - but it seems that all I had to do was disable / uncheck the “Edge Swipes” function in the Wacom Intuos Pro “properties” dialog box (“Touch” section). I might be able to love my tablet after all.

Thank you! I scoured the internet for this solution, and you were the ONLY person who had it. After over two hours of trying different failed solutions, this finally fixed my problem.

what happens when you press Windows Key + Ctrl + F4 ?

I did all of this , still got the multi desktop when I swipe from the left to the right :frowning: Please help

Also, if you’re wanting to disable Task View in the Taskbar for ALL users, you can add a DWORD ShowTaskViewButton with a ‘0’ value @ HKLMSoftwareMicrosoftWindowsCurrentVersionExplorerAdvanced and it should remove Task View from all users Taskbar.

Agreed. It was not there.

Try this. (This will disable all edge swipe, but shouldn’t mess with other gesture stuff.)

  Open regedit.exe, navigate to HKEY_LOCAL_MACHINESOFTWAREPoliciesMicrosoftWindowsEdgeUI
    (If EdgeUI is not present, Add a new key under Windows, named EdgeUI.)
  Set AllowEdgeSwipe value to zero (0).
    (If AllowEdgeSwipe is not present, add a new DWORD and name it AllowEdgeSwipe, then set to 0.)

That’s it. You may or may not have to reboot.



what happens when you press Windows Key + Ctrl + F4 ?

That does not work. I just spent 11 hours with several Microsoft technicians doing exactly what you are suggesting. I still have the task view interrupting whatever I am working on. Removing the icon doesn’t work. Setting that value to 0 doesn’t work. Reinstalling Windows 10 doesn’t work; you can’t stop the April update.

I don’t have a folder named Edge UI in that position in the Group Policy Editor? (on Windows 10 Home).