How to Fix 'Application-specific permission settings' Error

Originally published at: How to Fix 'Application-specific permission settings' Error

Windows 10 is the latest and the greatest operating system by Microsoft and the company has been pushing users to upgrade from the previous ones quite openly. It makes sense as well as there are several improvements in it over its predecessors. However, quite recently, a lot of reports have been coming in of “DistributedCOM(DCOM)…

I did all that! Several times! But the errors come back somehow…

Try running dcomcnfg as administrator by searching it in windows and selecting from the right click menu instead of using the r shortcut.

Yes, I had followed these steps a couple times and kept running into nanang’s error with the access denied. When I attempt to run as admin thru command prompt…still got access denied error

I cannot modify nothing on runtimebroker.
What can i do?

If you’re on Windows 10 there is no “NT AUTHORITYLOCAL SERVICE” it’s just LOCAL SERVICE. This worked. Thank you. After the version 2004 updates I got a ton of these. I’m just going to have to rinse and repeat. I know people say you can ignore warnings, but dang if fixing didn’t solve some audio problems I was having and the app I was using didn’t lock up.

Had the same problem. For me worked when I wrote only LOCAL SERVICE, is that the same thing or not? I really don’t know

Have you been able to fix this issue?

You have to click on the “Check Names” option to get the correct MS name or else it will fail, after entering the user name click on “Check Name” and select the correct one.

thanks for this

I get an error adding the NT AUTHORITYLOCAL SERVICE says its not valid

The following object is not from a domain listed in the Select Location dialog box, and is therefore not valid:
any suggestions? please

Modify the security permission for the COM Server application mentioned in the error message. To do this, you can use the Component Services administrative tool, as suggested in the error message.

Here are the steps to follow:

Press the Windows key + R to open the Run dialog box.

Type “dcomcnfg” and press Enter to open the Component Services administrative tool.

In the left-hand pane, expand “Component Services” > “Computers” > “My Computer” > “DCOM Config.”

Find the application with the CLSID mentioned in the error message (in this case, {C2F03A33-21F5-47FA-B4BB-156362A2F239}) and right-click on it.

Select “Properties” and then click on the “Security” tab.

Under “Launch and Activation Permissions,” click on “Edit.”

Add the user mentioned in the error message (in this case, FUJITSUusername) and grant it “Local Activation” permission.

Click “OK” to save the changes.

Restart your computer and check if the issue has been resolved.


I followed all the tips in this thread to resolve a few issues with the System Log, but still i am getting errors!

Tried adding LOCAL SERVICE, USERS, Administrator and Administrators!
Even added my own user FUJITSUusername (that has Administrator privileges)

Any ideas??


The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user FUJITSUusername SID (S-1-5-21-3351063332-3780512080-3317346159-1002) from address LocalHost (Using LRPC) running in the application container Microsoft.Windows.ShellExperienceHost_10.0.18362.1533_neutral_neutral_cw5n1h2txyewy SID (S-1-15-2-155514346-2573954481-755741238-1654018636-1233331829-3075935687-2861478708). This security permission can be modified using the Component Services administrative tool.

Hey @jamesscottwilkerson:disqus – might be too late or you’ve already solved, but in my experience, seeing these greyed out means you might have missed a step on the registry key permissions portions of the steps above or perhaps aren’t launching Component Services as Administrator. Re-check Steps 6-14 on this page. Cheers!

Worked for me! Thanks

What version of Windows are you on?
Seems to me that you didn’t grant the permissions correctly as indicated in the first couple of steps. Try repeating them carefully and then check if the issue is fixed.

Just user “Local Service” account instead.

Are u entering the name properly? check if there is an issue with uppercase or lower case letters. Also, if it doesn’t work, create a new administrative user and check if that works.

Proceed with the rest of the steps where u change the permission configurations and see if it fixes the issue for you. I think the value data step might have been added by mistake.

Try this: [FIX] "NT AUTHORITY/LOCAL SERVICE Cannot Be Found" Error

“An object named “NT AUTHORITY/LOCAL SERVICE” cannot be found. Check the selected object types and location for accuracy and ensure that you typed the object name correctly, or remove this object from the selection.” I got this error.