How to Fix DCOM Error 10016 on Windows 7, 8 and 10

Originally published at: How to Fix DCOM Error 10016 on Windows 7, 8 and 10

Getting a DCOM error with an Event ID 10016 means that a program tried to start the DCOM server by using the DCOM infrastructure, but the user doesn’t have the necessary permissions to do so. This is a known error that remains from older Windows editions, but it isn’t actually solved when you upgrade to…

Hey Davis,

Note that when you’re looking at the folders with the CLSID and APPID, you will see a registry key with the name of the service causing the issue. Read Step 12.

Between steps 16 and 17, no method is shown for finding the service that is causing issues. I assumed it would be in one of the subsequent “Roles” folders, but found each of them blank. Can someone point me to a more precise Directry to find it in component services?

  1. select “permissions” and click on “Advanced”.
  2. Right-click and choose permissions and select “Advanced”.
  3. Continue to step 15.

So… Step 3, 8, and 14 are incomplete. Please rectify the steps so we can at least complete the steps.

Grateful for this info, thank you.

What I do not understand is…

  1. Find the folder with the CLSID you received in the error message, then right-click it and select (SELECT WHAT FROM THE DROPDOWN?)

“If you receive a warning that one or more permissions entries attached has an unrecognized type, click Remove.”
You sure about that? Other forums ( for example, like this one: say to do not remove. So what actually happens when we clieck ‘Remove’? And what are the consequences?

No. You just have to reboot after performing all the steps mentioned.

So after reboote i have to do step 1 to 20 again ?