How to Fix IP Address Starting With 169.254

Originally published at: How to Fix IP Address Starting With 169.254

If your system suddenly has an IP address starting with 169.254 then it is certain that you will have no connection to the internet and neither to any network resource you previously had. Having this IP address is almost as good as having no IP address. In other words, you can say your system is…

I tried that and still have the problem,. For some reason my NIC occasionally loses it’s lease and self assigns. Can happen any time. Changed cables on router, changed ports, turned off power management on the NIC. Happens on both onboard NICs and the Wireless adapter but only on this computer, not my HT computer in living room. I nailed up the IP address the router is handing out in network settings and so far I don’t have any problems, SOHO routers like Linksys don’t appear to have the ability to set an exclusion like Cisco managed devices used in business so hopefully my router won’t assign that IP address to another computer. I’ve seen over time it consistently hands out in the range; default gateway is so I’ll keep an eye on a balloon message sating I have an IP address conflict. It’s a rig but the only other option would be to reimage my hard drive and reinstall everything back on the system and hope for the best. I can also try a third party NIC and see if I still have the problem of IP address dropout and self assign. If that fixes it then the motherboard manufacturer needs to be contacted about the problem. Thank you for your assistance.

I tried all that, I checked my router settings, it is consistently handing out for this computer. What I did to have Windows stop self assigning is statically assigning that 118 address. I couldn’t release or renew the DHCP lease using the command line, the only way out to pull an address for the router was to close all my applications and do a reboot on the OS. Sometimes the self assign would happen upon first bootup, sometimes it would happen at random during operation. I went into Device Manager/Power Management and unchecked the box where it allows the onboard NIC to go to sleep however this didn’t fix the problem. Nailing up the IP address, subnet mask and default gateway seems to be working as long as my router doesn’t hand out that IP address to another computer and I get an IP address conflict. I don’t see how to make an exclusion on a SOHO router like you can on a Cisco Systems router (dhcp excluded-address xxxx in global config mode) so I may have to upgrade the firmware to OpenWRT. Seems like this is a Windows problem as it happens only on this computer with both onboard NICs and the wireless adapter as well. I don’t want to have to reimage my drive unless I am absolutely certain this will do the job. Thank you.

Try to change your DNS Servers to and as secondary and check if that fixes the connectivity issue for you.

Ipconfig /release ipconfig /renew doesn’t work any more… message says parameter is incorrect. Only way to attempt another address pull is to ddo a reboot. Keep getting a DNS_PROBE_NXDOMAIN error and can’t access any sites other than Yahoo home, which is probably just a cached page. When I reboot I’m fine but I have to keep doing it over and over again. Only on this computer and not others so I don’t believe the problem is with the router. It’s either the onboard NIC on the motherboard or Windows OS itself.

Login into your router on a computer and enable DHCP it will enable it for all the devices.

If you have a USB network dongle and it picked up a proper IP and the network works fine then the problem will most likely be a firewall block on the mac address.

Can you make sure your network adapters are enabled?

I also have same problem .and after applying these command what it is writing?