How to Fix Keyboard Typing Numbers Only Instead of Letters

Originally published at: How to Fix Keyboard Typing Numbers Only Instead of Letters

Some keyboards are designed in such a way that you type letters at one point, then numbers at another when you press the FN or ALT key, along with the button that has a letter and a number either on top or to the side. For reasons that some users may not be aware of,…

Hi, thanks for the post. It help me a lot!

i used a different keyboard which had the NumLock key and hit that key. it worked.

Connect your keyboard to another computer and check to see if it still types numbers only.

I’m so angry this didn’t work

Did you try installing a different language, that can also change the settings of your keyboard, try and remove that language pack

It worked! hooo I got scared when half of the key are in numbers… lol
Thank you!

I have the same problem as u Shane. Have u found something to fix it ?

I have the same problem as u , is it fixed for u ?

It’s a Razer Black Widow, ultimate stealth 2016 keyboard, I tried it on another computer, turned off the macro stuff and num lock and still nothing, I even tried removing and cleaning the individual keys as well.

tnx for this, It helps me using method no.3.,

Put the computer in safe mode and check if it helps.

Thank you! the second step worked for me

Thanks! it worked for me

yay!!! I am able to properly type this message because of your help. thank you!!

Method 2 worked for me! Thank you.

Turning num lock off seems to fix it for most people. Connect it to any other computer and check if that helps.

Amazing it tots worked i was so scared cause it was my mums laptop, try this guys it tots works and i’m in Zambia so that’s a shocker it even worked. lol!

Superb!!! Worked for me, found the solution for my problem in the article’s third paragraph!

Thanks very much, you fixed my issue