How to Fix Remote Desktop Error Code 0x204 on Windows and MacOS?

Originally published at: How to Fix Remote Desktop Error Code 0x204 on Windows and MacOS?

Some users that are trying to connect to a Windows computer from a Mac, Android or a different OS have been getting the Error Code 0x204 when trying to use the Remote Desktop protocol. Although Remote Desktop is a robust tool that allows users to connect to a PC and get their access to apps,…

Okay, so there are some things that you can try to fix this issue first of all you will have to forward a port from your router’s setting and from your computer.

  1. Search for Command Prompt from Start Menu and run it as an administrator.
  2. Check your default gateway, copy it, and then use your browser to access that address.
  3. Once you are in your router settings it should ask for a password and username. (Check your router’s backside for username and password). If that doesn’t work you will have to contact your ISP to help you.
  4. Once you are inside your router settings find the section for Port forwarding and forward the following port:- 3389

Once the port is forwarded you will have to enable UPnP on your Windows here is an article on how to do it:- How to Enable UPnP 'Universal Plug n Play'?

Let me know how it goes!

Thanks Zubyan for your answers. I forgot to mention that I run Win7 on my (old) PC. I tried everything from disconnecting totally the firewalls or allowing all connections. Nothing works…

Have you tried checking your Windows Firewall settings? If not here is what you can try:-

  1. Press and hold the “Windows + R” keys together to open the Settings app.
  2. Head over to “Update & Security > Windows Security > Firewall & Network Protection”
  3. Now make sure to set all these settings to off click all the settings one by one and set them to off.
  4. Please revert them back to on after checking as it can cause serious security issues.

Hi Kevin
Thanks for your help.
I tried all the tricks and still does not work.
I can connect my Mac to my PC as far as they are connect to the SAME wifi network but I get the 104 or 204 error code as soon as I try to connect from another network… Any clues ?

Two MACs with different iOS ver both connect VPN ok but one fails DRC.
MAC using MS RDC ver10 get the error 0x204. From another mac at another location, running RDC ver8 there’s no problem using exact same credentials. I can conclude that the win pc is configured properly. the mac that does not connect is the first time trying.

Try this:-

  1. Open Finder
  2. Type “~/Library/Group Container” and check if you are able to access the folder or not.

Keep me updated.

No folder came up when I typed in Group Containers. Now what?