How to Fix the 'Failed to Acquire the VirtualBox COM Object' Error

Originally published at: How to Fix the 'Failed to Acquire the VirtualBox COM Object' Error

Several users are reporting that they are unable to launch VirtualBox. The critical error message that comes up is “Failed to acquire the VirtualBox COM object. The application will terminate”. In some cases, the error is also accompanied by a second error message pointing towards the problem. The issue does not seem to be specific to…


Method 3 works fine… Thanks.

thanks man <3

Thanks. Method 3 worked for me!

thank you

I’m not sure that is relevant to this article, we have although noted your query and will notify you when an article is written on the subject. That is unless you have found a workaround to it by yourself.

i am getting problem that my ubuntu is not installing anything ,please help me

the 3 methods didn’t work for me but i found a simpler work around.
Solution : Open the virtualbox folder and notice the virtualbox xml file with 0 kb size and delete it. Run again your virtualbox and all works ok due to the recreation of a new xml file.

Thanks. Method 3 worked for me also!

I actually tried all three methods but none worked, BUT I found a solution:
Go to Local Disk (C:)UsersYOUR USERNAME.VirtualboxVirtualbox.xml and open it with notepad.
Now open command prompt (don’t close that notepad I told you to open) and type in: wmic path win32_computersystemproduct get uuid
you will see a 36 character format, copy it, now open that notepad and find the place where it has soo many zeros, select them all and replace them with your UUID (the thing that you just copied) and save the notepad, now open virtual machine, ****this is a rare case for me.

Thanks. Method 3 worked for me also. I has indeed been a great help.