How to Fix 'The Local Device Name is Already in Use' Error on Windows?

Originally published at: How to Fix 'The Local Device Name is Already in Use' Error on Windows?

The error ‘The Local Device Name is Already in Use’ is associated with complications in network drive mapping and is commonly encountered by individuals who often interact with networked systems. The issue occurs when users try to access a network drive but are met with the following error message: An error occurred while reconnecting <drive…

It means that the service isn’t installed in your computer, have you tried other methods?

Yes, delete the drives and remap them again. Use the command provided above and let me know how it goes.

This depends on your Windows language settings. It will not be named “Computer Browser” unless you’re using an English Windows.

Not sure which version, but in newer versions of Windows 10, you should try restarting the Workstation service.

net use z: \BohrDataMusic /user:xxxxx xxxxx

Multiple connections to a server or shared resource by the same user using more than one user name are not allowed.

net stop “Computer Browser”

The service name is invalid.

Hi again.

I just wanted to thank you for all you efforts attempting to help us on this.

My boss’s solution was to replace the NAS. That seemed to have worked so far. Well, at least until the next time.

Thanks again for your help.

Yes, I can ping when the “device name is already in use” error comes up (which is what’s happening right now).

Which Net Use command are you referring to? I tried stopping and starting the computer browser, and there were no problems doing that but it did not correct the problem. The only other net use commands I see here are for deleting and remapping the drive.

Which one would you like me to test?

Thanks for your assistance on this by the way. It’s very frustrating.

This did not fix anything for me, I can remap the drives and after a random time later it is back

Hi Plamen,

i have the same issue. Did you found any solution!

Best regards,

I have been very busy so I have not had a chance to waste more time on this, but we have upgraded a few more computers to Windows 10 and on every one of them, the network mapped drive for our NAS is doing this same thing.

If I delete the mapped drive and remap it, it works. But if I reboot the PCs, the drive fails again. I have tried using both the network name and the ip address. I have changed the value of the PorotectionMode bit from 1 to 0, and it did remove the red X from the drive after rebooting, and it seems as though it was going to work as it actually opened a window, but then “Specified network name is no longer available” error and it will not work again.

We had used this NAS for years in Windows 7 with no problems. We can access the NAS using a web browser and we can ping it from the command prompt, but the mapped network drive will always produce one of the two errors unless I delete it and remap it, which only lasts until the next boot.

The NAS is a Lenovo iX2. I have had to install SMB 1.0 just to get the NAS to work, otherwise we couldn’t access it at all. I had to do the same thing with my older ReadyNAS Duo at home, but I am not having any issues with it in Windows 10. I also have mapped drive set up to another computer in our shop that is full of service manuals, and it does not do this, only the mapped drive for the Lenovo NAS does it.


Thanks! Worked!!

Thank You!