How To Fix the Missing Install Button on Windows Store

Originally published at: How To Fix the Missing Install Button on Windows Store

Windows Store has a number of different apps you might want to get as soon as you see them. And getting these apps is as easy as scrolling past them. But if something is wrong, the Windows Store might not allow you to download apps. This occurs due to several reasons and can stop you from…

You can’t get into the settings for Windows Store? Open Command prompt, type wsreset.exe, and press “Enter” to execute the command.

I can’t access settings at all. I’ve tried everything else in several guides and nothing is working. It may be as simple as getting into settings except that not even that is simple with this awful operating system! Nothing works right!

just restarted and problem solved.

yeah me too, what must i do?

I created a Disqus just to reply that you have saved me from insanity, thank you!

Yeah, ended up restarting my PC and it fixed it, must be update operations.

Windows update fixed that.

Did you ever find the solution, I’m stuck where you’re at.

I can’t even access to settings. When I click on settings the store hangs.

Missing Install Button on Windows Store fixed

what to do is just following simple steps

  1. open microsoft store
  2. go to setting from top right corner 3 dots
  3. turn ON offline permissions


Please run and install all available updates from Microsoft and then check.

Is the install button missing on all apps or just a few?

I created a new MS user that I logged in with, no help. I even used the same MS account that I use on my primary computer.
Both compiters are upgrade from W7 when the free upgrade was available, so they should be “identical”.

Have you tried creating a new user account?

My problem is that I installed the Netflix app on my main computer via the store, worked fine, but when I was about to do the same thing with the computer I have hooked up to my TV, I noticed that there is no install/get/download button on any app. I can see purchase buttons, but no install/get/download.

I’ve tried to reset the store, log in with a new freshly created MS account for that computer. I even tried a PowerShell command that seemed to not work, as I got no feedback from the computer what so ever, even after letting it be till the next day… and ofc I’ve tried to reboot the computer.

What could be wrong? is it a matter of MS account that has to be validated and confirmed for this to work, or will it work with a local account also? I don’t know where to keep looking for the solution.

Thank you so much. Restarting my devise actually worked! Now I can download anything without having to worry! Thanks Appuals!

Missing on all apps