How to Fix Wi-Fi Not Connecting Automatically on Windows Startup

Originally published at: How to Fix Wi-Fi Not Connecting Automatically on Windows Startup

Wi-Fi not connecting automatically on Windows startup can be a frustrating issue. It may stem from the power options settings of your network adapter, incorrect network drivers, or interference from third-party applications with the network adapters. Wi-Fi Not Connecting Automatically in Windows While this behavior doesn’t prevent manual connections to Wi-Fi networks, it’s not the…

Enabling the " put wifi to sleep" did it on my Lenovo B50 , my problem was that the wireless adaptor was enabled but didnt connect automatically to the network, had to disable-enable manually then it would work . Thank you very much

Registry editor solution worked for me in 2021

I had tried everything above except 1 thing. Nothing worked. Tried different drivers. Same issue would not auto connect. The thing I originally did not try was to ENABLE the computer to turn OFF the device to save power- because that just seemed plain backward to me- well finally I tried it- and it worked! Well lesson learned. An easy step, no matter how illogical, is low hanging fruit when it comes to fixing windows issues.

It could’ve fixed itself because in some (Rare) cases windows tends to fix itself by updating.

Check out this Screenshot of my settings, the option is clearly present in newer versions of Windows 10 pro.
https://www21.zippyshare.com/v/17QapIHX/file.html
Which version are you using?

He might mean the “Mobile Hotspot” option and the “Turn on Remotely” toggle in that setting

Is their any option in windows 10 or router configuration ?? what is that means when i connected one router if it is giving poor connection then it will connect automatically to another router in same network .!!

I had this same problem with Windows 10. The only thing that worked was the registry edit.

You can follow the long and winding road (open regedit, navigate blah blah, create blah blah…) or just run this from an admin cmd:

reg add HKLMSoftwarePoliciesMicrosoftWindowsWcmSvcGroupPolicy /v fMinimizeConnections /t REG_DWORD /d 0

Copy, paste and enjoy.

this fixed my dads problem, thanks to all contributors! <3

Disabling Microsoft Wi-Fi Direct Virtual Adapter worked for me. Thanks heaps for the help!

I solved the problem very easily

  1. Within the device manager, under VIEW, choose “show hidden devices”
  2. disabled the “microsoft wifi direct virtual adapter”
  3. restart
  4. done :slight_smile:

Thank you

Thanks.
Creating a new DWORD in Registry editor was the solution for my windows 10 to connect automatically.

I tried all of the suggested methods + more from all google results with no joy.
Windows 10 1809 64bit - Ethernet Connected with PCI-E Wi-Fi card.
I finally managed to get it to work using the following.

Config this settings via Group Policy Editor:

Computer Configuration → Administrative Templates → Network → Windows Connection Manager → “Minimize the number of simultaneous connections to the Internet or a Windows Domain” to “Disable”.

Just wanted to thank you for illustrating how to get Windows 10 to connect to the Wifi. Been fighting this for a long time…such a relief to have it FIXED!!! Many many thanks.

Yeah. Bill could be more philanthropic by reimbursing us all for the crap that’s been foisted on us rather than spending billions on ridding Africa of malaria - the most effective form of population control that continent has.

The registry bit worked , great, and on my desktop and laptop, Thanks

K. Arrows don’t apologies for a late response you’re not technical support. Jaymie Johnson This person offers a free webpage for helping with issues. You pay for nothing so don’t expect a timely response.

Yep - Hacking the registry was the answer to fix this problem. Presumably the latest Win10 update had removed the GroupPolicy key (well done MS!). Thanks Kevin.