How to Fix Windows 10 Can’t start your camera error 0xA00F4246 (0x887A0004)

Originally published at: How to Fix Windows 10 Can’t start your camera error 0xA00F4246 (0x887A0004)

Following a fairly major Windows update rolled out in September 2016, many Windows 10 users have started reporting an issue where Windows 10’s stock Camera application fails to access affected computers’ cameras and an error message containing error code 0xA00F4246 (0x887A0004) is displayed. The full error message reads: “Can’t start your camera If you’re sure…

You can delete it since you created it yourself.

hye, I just did as told. but after I restart my laptop, the fans spin really fast. was a bit scared. and the camera still shows the error. my question is, can I undo what I just did? I decide to delete the EnableFrameServerMode. can I just delete it? or is it require any steps that I must do in order to delete it?
thank you in advanced

I resolved this after a fresh install of Windows 10 (1709) on my HP Spectre x360 (15-bl112dx) with TrueVision FHD RGB-IR by re-enabling some windows services that I had disabled when trying to reduce my footprint… I believe the culprit was Windows Camera Frame Server. I has switched the Startup type from Disabled to Manual (triggered) and the errors went away. This is probably the same as editing the registry key. Windows Hello also started recognizing the camera face recognition capabilities. if your issue is similar first check what has changed with the service(s) settings you may have modified compared to the vendors settings. This has nothing to do with the driver or missing software!

Thanks a lot!

Dude, i have been looking for the solution of this camera problem over a week now, and searched nearly every relation forum, they all said install this, activate that, nothing worked, but this one did. You nailed it bro, thank you so much ! Also i would appreciate a lot if you could tell me how did you figure out that this entry will do the job.

Dude, thank you very much, it really works! BUT: please, write the full path where the DWORD should be created - I’m pretty sure there will be somebody else who would miss that the key-folder is “Platform”, not the “Windows Media Foundation”. Like I did:) I found my mistake after 3rd reading. Of course this is my bad, but if it is not difficult for you to put the full path in the registry, please, do it.

worked like a charm. Be sure also to grant access to the camera from the privacy settings. Thanks for the tip

hye man, I still cant fix my camera. it has been a headache for me since I knew I cant open my camera. can I just undo what I just did, because after I restart my laptop, the fan spin really fast. I was scared a bit. can I just delete the EnableFrameServerMode?

Did you solve the problem? I have the same error code. Before I also try the registry edit.


I tried your registry edit, but my camera still does not work. I do not know if it is significant, but while the first part of the error code is the same as mine, the parenthetical error code is slightly different. Mine reads (0x80070057). The other is (0x887A0004). Any help is appreciated. Thanks.


Thank you this fixed my problem!

I tried all the possible ways.Went through the microsoft forums for solutions but nothing is working.I even tried to restore my system to a point but its failed.Some error showed up saying your antivirus blocked the restore.I even disabled my antivirus (I use Kaspersky)but the same error message is displayed.I’m attaching the screenshot if my error.Please help me find a solution to this problem.

Thanks dude! Finally got my camera back. It works!

researched it :slight_smile:

Hi. I nearly threw away my laptop. Your thread helped me. THANK YOU THANK YOU THANK YOU!!!
God Bless you!!!