How to Fix WSL Register Distribution Error 0x80370102?

Originally published at: How to Fix WSL Register Distribution Error 0x80370102?

This error arises when users try to install a Linux distribution to access via Windows Subsystem for Linux 2. After reviewing the user’s feedback and technical authorities in detail, users reported encountering the error message 0x80370102 when trying to install Linux Distro for Windows Subsystem for Linux 2 (WSL2). The error notification is as follows:…

God among men. Solved my issue

Yes thank you so much, this is the only thing that has solved my issue

thanks a lot !!! I made it by enable SVM (BIOS virtualization)

Kept getting the pesky 0x80370102 error when trying to install Debian from the MS Store and LinuxMintWSL (from github).

  • SVM (BIOS virtualization) was enabled

  • Hyper-V installed and enabled

  • Windows Virtual Platform installed and enabled

  • WSL installed and enabled

  • WSL Kernel update installed

… basically all the requirements were met, but I still kept getting the error no matter what.

The fix for me was to first set WSL default to v1:
(Windows PowerShell Commands As Adminstrator)

wsl.exe --set-default-version 1

Then install the distros. Once the distros were installed, I upgraded them to WSL v2:

wsl.exe --set-version Debian 2


wsl.exe --set-version Mint 2

Then I verified the versions with:

wsl.exe -l -v



Debian Running 2
docker-desktop Running 2
Mint Running 2
docker-desktop-data Running 2

Then I changed the default WSL version back to 2:

wsl.exe --set-default-version 2

And finally tried to run my distros in Windows Terminal and they worked fine. Was then able to
sudo apt update
sudo apt dist-upgrade

So everything appears to be working now.

What fixed it for me in powershell as admin:

Get-Service LxssManager | Restart-Service

You just have to enter the name of your Virtual Machine. That’s it.

Thanks for ur help, but I acltually don’t know why now it’s working. Thanks again !

It should also be enabled in Windows Settings try method 2.

Hi ! I have enabled Virtualization in the BIOS, but I still have the same error. Any idea why ?

Hi ! How can I get the name and values of my VM Processor ?

When I past the command in admin powershell it gives me error. What should I do?

Windows 11 is basically similar to Windows 10 In some cases, I suggest you try the methods shown and let me know how it goes.