How to stop 'Windows 10 installing Realtek Drivers automatically'

Originally published at: How to stop 'Windows 10 installing Realtek Drivers automatically'

Previously one would choose the settings to update windows and device drivers. However, after the release of Windows 10, most updates are forced on your system. Apart from the Windows Build updates and forced hot fixes, Windows 10 now updates your device drivers in order to keep your system working at the highest efficiency. This…

bro u r the best it really worked for me thanx

method 1 worked(somewhat),it took me so long to solve this problem because of my driver installed on the dvd that came with my mother board was faulty so i took a driver from the website of my mother board

Did you try to disable the automatic installation of the Realtek drivers? seems to me that the Realtek drivers are causing the issue.

If windows still ignore your suggestion, then im afraid there isn’t really any way to get rid of the automatic installation of the drivers.

The most insane part tho, that even disabling auto drivers install in the advanced system settings, unistalling it completly, windows 10 amazingly ignores you opinion and silently straightly install it again. Cuz why not, good old windows 10 right? Windows 10 is terrible and IT IS the worst OS in drivers. More problematic than vista actually. The reason I want to kill the Realtek driver to my laptop completly, is because recently on the 1903 version, the system sound does a terrible delay AND a odd audio “skipping” during playback. Not just to this, but everything that uses the wav codec or something. It REALLY broked my system. Also, when I suspend my pc and turn it on again, the sound…literally mutes, forcing a restart.
It never were like this. More updates, some stuffs may be fixed, but adds more headaches.
Would be appreciated if someone find a TRUE FIX, ok? :slight_smile:

If you cant see it and are convinced it is installed, click on the “View” option in the device manager and select “Show Hidden Devices”. Now Open the Sound, Video and Games Controller driver dropdown and you should be able to see Realtek Drivers there.


Have been dealing with this problem for what seems like forever. None of the methods I have found online ever seem to totally work. Since there seem to be a never ending plethora of issues with Realtek, why can’t I just remove it from my system forever…!? Hopefully, one day maybe, Microsoft/Realtek will finally get the issues fixed, and I can re-install it at that time.

BTW, even after the install and following the instructions online, I have NEVER been able to find the Realtek manager anywhere on my system…???


I had a similar issue with the Conexant driver and it’s various utilities and services stubbornly reinstalling on the system. I believe that a similar solution could be used for Realtek drivers.

  1. Find out the name of the Realtek driver using MSINFO32. It will be under Components - Sound Device. Something like C:windowssystem32driversRTLHD64.SYS. Write this name down.
  2. Under the Programs and Features Control Panel, uninstall the Realtek driver item. When finished, DO NOT choose to restart the system.
  3. Navigate to C:windowssystem32drivers and create a FOLDER named RTLHD64.SYS - or whatever the name you wrote down. This will block the driver file from ever being reinstalled and prevent the installation of the various services and utilities.
  4. Reboot and the Windows should install the generic Windows High Definition Audio drivers.

Excellent article. Solution 1 worked for Lenovo Yoga 720 13IKB…after trying many other solutions from inferior websites. Your logic and familiarity with microsoft’s sociopathic corporate ethic is apparent.

Have bookmarked your site.


Hello all,

i am reading this topic and i have a problem with sound too…i will try to describe in details:

so sound is working normally in windows and in example youtube…BUT in half of games which i play i dont have sound…

now this is what i tryed: i have realtek driver installed and updated.

now when i do this i get sound in all games:

  1. edit realtek driver and replace it with “high defenition audio device” then i deinstall realtek program → i get NO SOUND
  2. when i restart laptop and login i get sound in windows and youtube BUT in half of games no sound…
  3. then i click windows update which again found realtek and update it…so im back on realtek again → again no sound in half games…
  4. restart AGAIN ----> guess what i have sound EVERYWHERE so everything ok… PROBLEM IS that works only until next restart and then im back to first step…

i really dont know what to do i tryed everything…its obvius its driver conflict but i cant get sound to stay after that third restart…

any ideas?

Best Regards

Sweet, Method 1 works, thank you so much sir <3

KUDOS!!! Method 3 solved it.
This should get better SEO

Did method 1 and THANK GOD!!! Realtek does not update anymore.

Have you tried disabling updates?

The Realtek driver needs to be fixed ASAP!

I found out that sometimes, it still says “Realtek (R)” but when you check its properties, the drivers are actually Windows High Definition Audio. It just doesn’t change the hardware name for some reason. Just go to Device Manager > Realtek (R) Audio, then right-click to Properties.

try rolling back the intel sst driver under system devices in device manager then , then unistall the realtek (R) driver then u should be able to have the high definition permently(worked for me).

Method 1 works very well with small modification for laptops; Disable the Realtek device-click update driver-browse my computer for driver software-let me pick from a list of available drivers-then uncheck the tiny box “show compatible hardware”. It will reveal a large list and one can browse to Microsoft then choose “high definition audio device 2018” to install!

Those drivers are HD they are just named Realtek(R). Do you notice any difference in sound quality?