How to Update BIOS On Lenovo

Originally published at: How to Update BIOS On Lenovo

BIOS stands for Basic Input Output System. It’s a set of code that resides on a chip on your system’s motherboard. When a computer boots up, it looks to the chip for BIOS instructions on where to find the operating system. Among many other things, BIOS also facilitates communication between the operating system and the…

Check if this article helps you: This PC can't run Windows 11 [Try these Solutions]

Can you elaborate on your request?

Lenovo Service Bridge DOES NOT WORK! Use Lenovo Vantage.
I just tried to update my BIOS on my Z50 laptop. It failed. Told me to press any key to reset. I pressed all my keys and nothing happened. I had to power off manually. Thankfully it did not brick my laptop.

How to update serial number and model of lenovo g50-45 laptop?
It show invalid
I replace new modherboard throw market.
Please help .

Same issue on T440, did anyone ever find a solution?

T440 same issue. Long shot but did you guys every fix this? It tells me the program cannot run in DOS mode. Trying to update the BIOS after an update with Lenovo Vantage resulted in a “2100 Detection Error” that left the BIOS unable to see the hard disk. No option in the BIOS to manage the hard disk settings. This was my last ditch effort before I toss this trash in the garbage where it belongs.

I’m having the same issue, were you able to fix this?

some time ago I accidentally installed ubuntu on my whole HDD, so all the partitions and files (including recovery partition) were erased. I then installed back Windows 8 and partitioned the HDD.
however, since the incident, I’m unable to enter BIOS. I’d like to change boot sequence, because the laptop wants to boot from network, displays an error, and then boots from HDD and Windows 7 starts. I can access boot manager with F12 during boot, and the entries are

  1. ubuntu
  2. booting from network
  3. booting from HDD
  4. booting from DVD
  5. booting from USB

. i tried your second method since first one didnt work for me, after typing command “WINUPTP -S” i was getting a message “this program cannot be run in DOS mode”.
please help!!
Thanks in advance

It seems like the system isnt able to hold the date and time, could be due to a weak battery before trying out anything else can you replace the cmos battery, set the date and time and then see?

try it, but make sure data is backed up to avoid unforseen loss of data.

Hello, I want to try it using the first method but I’m worried my laptop will be out of commission too long. How long does it actually take? From the picture you can see I just need to press update which seems simple enough, but whats the usual duration of the whole thing?

When you say it didn’t work, how did you actually check? Thanks

I tried to update with a bootable usb drive my T440. Both (image for cd and Windows Update Application files) don’t work for me.
The drive with the cd image didn’t boot and the freedos drive with the data from the windows package throws the error, that this is not a dos application.
I’m trying it with the latest files from the lenovo website. Any ideas how to get this to work?

Thanks in advance.

It’s funny, really… Turns out that my PC or motherboard generally supports TPM (at least version 1.2), but I can’t enable it in BIOS. lmao

Also, there seems to be no update available for my motherboard’s UEFI…

So stupid! :frowning:

Did you flash the bios correctly? if the computer isn’t working the only solution is to take it in for service.

Sir i have lenovo b490 model laptop.after bios update my laptop not working. Screen is always black.only power light is glowing…what can I do sir?plz help me

I experienced the same. Error message says “This program cannot be run in DOS mode”

After bios updating my thinkpad e330 is now showing blank screen always. Only if i remove the cmos battery and press power button for 5sec down ,it will boot for like 15 sec. then give me an error message “real time clock error check date and time configuration changed restart the system”
I used your post to configure a boot usb, problem is the laptop will turn off before i get the chance to enter bios. Fn , Fn12 , Fn1 dont help. What can I do ? How about flashing the bios chip and how to do it ? Thank you