SOLVED: File Explorer Not Loading or Loading Slowly After Windows 10 Upgrade

Originally published at: SOLVED: File Explorer Not Loading or Loading Slowly After Windows 10 Upgrade

After upgrading from an older version of Windows to Windows 10, quite a few users started experiencing an issue with File Explorer where File Explorer would either simply not load anything or load data at an incredibly slow pace, often resulting in only a small part of the data being loaded. This was an issue…

Yes it is an important feature, but users who don’t require it can speed up their computer if they can’t afford an SSD or a new hard drive.

Right-click on your taskbar and hover the pointer over to the “Search” option and select “Show Search Bar”.
the Windows Search option is integrated into every version of the Windows.
If the above solutions don’t work press the “Windows” + “S” Key on your keyboard to navigate directly to the search bar.

Go into settings>Advanced> scroll down and disable the “Use Hardware Acceleration Where Available” option.

Finally! It worked! I’ve been searching through different kinds of solution and this is the only one that works for me! Thank you! ^^)

Worked like a charm for me. Thank you very much.

Worked like a charm for me! Thank you so much.

We fixed the problem by re-profiling the user. We tried this because we noticed that if you logged into the same computer with a different user, the problem did not occur.

That solution is for users who are facing this issue with few folders. If you have a lot of folders try the other solutions provided. Let me know how it goes!

In solution 3, after letting explorer load slowly, you have this instruction:
“locate the problematic folder and open it.”

How do you locate the problematic folder? Do you just go through every one and look for one with a Date column? I have at least a hundred folders, all with sub-folders.


my issue is specific to google chrome and file manager.
when trying to upload an image from google chrome the folders are very slow to open.
no issue using IE or firefox. any suggestions?

OMG… Many thanks to youu

I have a pc with windows 10 mini OS v2017.09 and it doesnt have windows search installed but it has that problem, windows search doesnt exist, what I can do?

Why would you want to disable the search service on your computer thus making your files harder to find (and take longer too)? This is like a core feature of Windows. If it’s slow then you’ve got some other issue like a super old hard drive that reads slow, or some other processes that are slowing down your machine, or it’s indexing locations on your drive that don’t need to be indexed (i.e. windows and program files). My two cents…

Thanks a lot !!! This worked great.

Just spent the past week trying to figure out how to fix this and this did it. Thanks a bunch!

After trying many suggestions to fix this problem, I finally stumbled upon the culprit–OneDrive. After I disabled it, Search ran normally and scrolling worked fine.