[SOLVED] One of the Update Services is not Running Properly in Windows Update

Originally published at: [SOLVED] One of the Update Services is not Running Properly in Windows Update

One of the Windows update services might not run if an application on your system (like StopUpdates10Guard) is hindering the operation of the update modules of your system. Moreover, the wrong configuration of the Windows Update or BITS services may also cause the error under discussion. The issue arises when the Windows update fails to…

That’s really unfortunate, can you try creating a new administrator account and check if you are still facing this issue on that new account?

You will have to download a 3rd party tool in order to get the permissions then. It’s a small tool that basically allows you to open files with all permissions. Follow these steps:-

(Warning: With great power comes great responsibility, please don’t use this app to run any other program otherwise there will be some serious permissions issues or if the program is any sort of virus it can infect your computer with full permission. Also, setting up your registry incorrectly can cause instability in your computer. Please make a restore point before making any of these changes we won’t be responsible for any damage done to your computer.).

  1. Download NSudo from this link: NSudo.exe - Google Drive
  2. Once the NSudo is downloaded. Simply right-click on NSudo and run it as administrator.
  3. Now make sure the selected user is “TrustedInstaller” and the “Enable all privileges” option is checked.
  4. Now type “services.msc” and press “Run”.
  5. Once you have done that you should have the Services window opened with all the permissions.
  6. Simply do all the steps provided in the article and your issue should be resolved.

Let me know how it goes for you so we can add this method to the article as well. Thank you!

You can add me here: Zubyan Gul#9955

I think there is a policy/registry key enforcing this change. Do you have Discord?

Can you try Method 2 from this article?

i tried it, it helped a little bit, but now windows update startup type is: automatic (Trigger start), and it changes to “disabled” when i press properties again. https://uploads.disquscdn.com/images/d8a6d640d517ce79469b98a60f9f836bf75aa5fa15c35b354000bb9b17f818fb.png .

i got the Error 1058 when i tried to do step 3
Please help

Hi Zubyan, I tried these steps and it didn’t work. I still get Access Denied despite following your clear steps.

I tried this but when I get to step 3 it says access denied, Please someone help me

Hey Kevin,
Thanks for this guide! I went through 5 different guides step-by-step to resolve the system update issue, and gave up on it. Today I went through all your steps and the fourth one finally fixed the issue (!).

Yes I do have discord

Can you please attach a screenshot of the error you are facing?