Solved: You'll need a new app to open this ms-windows-store

Originally published at: Solved: You'll need a new app to open this ms-windows-store

Windows Store is a concept introduced in the Windows 8.1 OS but it’s not something new for the world of technology as the vast majority of smartphone operates by using an app store which is used to download apps and games to your device. However, this makes the process of installing programs and games on…

You can press “Restart” instead of ending the task. Then you can proceed with ease.

Go to:
This PC>C Drive> Users> Your Username> App Data> Packages and delete whatever is in there even if it looks different to the screenshot.

Click on “File” in task manager and select “Run new Task”. After that, type in “explorer.exe”, check the “Run this task with administrative privileges” box and click on “OK”. Now continue with the steps.

Create a new administrative account and try again.

Solution 1 just helps in clearing the cache that is stored on the device by different applications. This cache can sometimes be corrupted due to which it can interfere with the launching process of certain applications. If you follow the guide accurately nothing would go wrong with your installation or Windows since the cache is automatically regenerated.

Are you able to open run dialog?

Are you able to open run dialog?

After I end task for windows explorer how do i re enter it in step 7

Not at all, as soon as windows explorer task is ended windows key and all open run prompts are closed. No way to progress for me in solution one beyond end the windows explorer task. End up having to reboot every time.

Sorry but I don’t trust the instructions. Personally, I need a summary or line explaining why we are going to do something (or WHAT we are going to do). Having just a list of steps, particularly the way it was done solution 1, makes me very wary … and unwilling to give it a go (though I AM desperate to fix this)


Hi, I’m on the (only) Admin account but it’s still telling me I need permission to make changes and won’t let me delete anything in the Packages folder. How do I get around this? I’ve checked permissions under Security and it says I have full control… Dam MS

It worked, thank you :slight_smile:

Are you able to open run dialog?

Solution 1 is perfectly worked for me, many thanks :slight_smile:

Are you able to open run dialog?