FIX: Asus Computer Boots Into Aptio Setup Utility Instead of Booting Into its OS

Originally published at: FIX: Asus Computer Boots Into Aptio Setup Utility Instead of Booting Into its OS

The Aptio Setup Utility is kind of a variant of the BIOS setup utility, although the Aptio Setup Utility usually only comes with Asus desktops and laptops. Quite a lot of Asus computer users have faced and continue to face an issue where their computer continuously boots into the Aptio Setup Utility instead of booting…

Shane Warren, thank you for the reply… I’ve already reach my limit in analyzing what is the problem. So I already hire a hand to help me with this problem…

It’s now telling me to reboot and select proper boot device or insert media in selected boot device and press a key?? How do I fix this please!?

SUCCESS: After days of taking parts out of my computer and changing the BOOT and SECURITY tabs in the Aptio screen, I called ASUS. They directed me to disconnect the power, and to hold down the power button until the notebook shuts off. Then, HOLD THE POWER BUTTON DOWN AGAIN FOR ABOUT A MINUTE. THEN PRESS THE POWER BUTTON TO TURN UNIT BACK ON. It booted up normally. They feel the hard shut down also shuts down some of the things running in the background that, perhaps, are too much for the computer to run at once. [Perhaps they are correct, as I was able to get it to boot up a few times prior to their assistance and only crash again.] I’ll call back if needed but so far, this easy solution has been successful.

It works after the last description ‘… enable CSM …’. Many thanks!

i got to this screen too but everytime i press f10 it takes me to the screen that says reboot and select proper boot device

same problem, did you solved it already?

Alright then, thanks a lot

I did not do step 1 because I do not feel comfortable opening my laptop and I don’t know how to locate the motherboard much less the drive connected to it. I am trying the second set of steps but I do not have the options under security that you list. All I have is Administrator Password Status, User Passeord Status (in grey); Set Up Administrator Passeord, User Password and I/O Interface Security. I also do not have a CSM launch option though the UEFI Boot is enabled. I have an Asus ux21e

Hello, I’m having a problem similar to this and i was wondering if you could be able to help me. I own a 2016 Razer Blade with a full hd non touch screen and a 256gb ssd. A few nights ago, I was on youtube when windows had an error, and it had to restart. It booted off and when it started back up, it would not boot into the OS. It gave me the error 0xc0000454, which has to do with a boot file being corrupted or changed. I have tried many solutions but i’m not sure what else to do. I used a recovery usb with windows on it and in the troubleshooting option and inside the command prompt, using diskpart and list volumes, I only get one volume, the usb i plugged in, as if my current ssd was not present, when it is. Is there any way you could help?

After doing your steps an restart my laptop “Missing operating system” is what came on the screen how do I get rid of it please reply asap

Hey Kevin , my eeebook Asus x205ta is stuck in aptio setup utility, and I navigate to the "“Boot” and it shows NO options, it is absolutely EMPTY…no fast boot, no launch csm, NOTHING(((( do u have a solution in that case? Please help

Having no secure boot option isn’t an issue but to find out why it is not there is going to take time. Generally, this is the criteria that has to be met in order to have the option.

  1. The partition have to be GPT instead of MBR
  2. Windows 8 or 10 has to be installed with UEFI/EFI activated
  3. Secure Boot have to be enabled [this is dependent on 1 and 2]

#6 I navigated to the “boot” but where do I find SECURE BOOT? The only options I have are 1. BOOT CONFIGURATION 2. FAST BOOT 3. LAUNCH CSM AND THE 4. DELETE BOOT OPTION

thaaaaaaaaank you man your tips saved my laptop

I did what you say but rather than going to OS , it shows " reboot and select proper boot device "

see here:

Should be taken to a shop, since you’re limited by options to try.

Can you create a bootable media and follow the prompts? You’ll need a different computer/laptop to do this.

I Just bought a new computer without OS, so i bought windows 10 online and made a bootusb now when i start up my computer it stays in aptio setup utility

How can I instal windows 10 on my new pc…