Fix: DISM 'restorehealth' error 0x800f081f

Originally published at: Fix: DISM 'restorehealth' error 0x800f081f

All versions of the Windows Operating System come with an abundance of different tools and utilities that are at the service of Windows users should Windows ever require repairs of any kind. One such tool is the Deployment Imaging and Servicing Management (DISM) tool. The DISM tool can be used through any Command Prompt (with…

DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:SourcesInstall.wim:1 /LimitAccess

This is the command, just replace ‘X:SourcesInstall.wim’ with your image’s directory and it should be good to go.

I used the ISO from MediaCreationTool.exe, turned the install.esd into install.wim and tried a handful of commands in different order but in the end using capitalization it seemed to work. Maybe it’ll work for you?

I don’t think the other commands I did mattered, but try running the Dism /Online /Cleanup-Image /RestoreHealth /Source:WIM:C:UsersTylerDesktopinstall.wim:1 /LimitAccess command with WIM capitalized. Also, not sure if it mattered but I also extracted the sources folder along with the install.wim file because the error I kept getting was it couldn’t find sources and to define it via command line.

Let me know if that helps, I’ll post the other commands if it doesn’t - this was the other forum post I was trying (commands in there somewhere, very similar):


Very informative article but it’s not working for me. It doesn’t matter whether I have the image mounted (I’ve mounted it with the Windows service and also with Daemon Tools) or if I copy the install.wim directly to my desktop and try from there. I downloaded the ISO from the link you posted in the comments (Download Windows 10 Disc Image (ISO File)) since the techbench link is no longer available. I’m at a loss for what to do. Is my syntax incorrect? Frustrating.

“We are sorry, the page you requested cannot be found.”
Also the original link in your article worked for about a minute and I managed to click ‘Confirm’ but then it said “Your request encountered error” or something like that… after refreshing the website the original message “We are sorry, the page you requested cannot be found.” showed up…
And what’s the wierdest, when I open Microsoft homepage this message shows up again.
What’s the problem here?

The link to download the Win10 ISO is not working, where can i download the same win10 iso version?

IT’S REALLY FIXED. THANKS MAN! I thought that I can use my iso (not the one he provides, sorry) but it’s always failed. After I download the one he provides, boom, it’s fixed.

For those who had trouble with dism, just download the iso form techbench

(Hmm posted response didn’t appear)

Yup, still having problem with Explorer.
After restart, I can update/modify items on the Desktop.
However, as soon as I open File Explorer, I cannot change/modify items in FileExp and ability to on Desktop stops.

After restart this morning, I got an automated attempt “to find a solution” but nothing was found.

It repaired the system corruption. Still having issue with explorer?

Thanks Kevin but now I’m not able to run Windows Defender (0x8007139f)

You need to type the command starting from DISM.

I’m not able to reach in cmd the same which is on your picture (C:users>). Can I type the command as “C:Windowssystem32>DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:H:SourcesInstall.wim:1 /LimitAccess”?

Yes, Method: 1 worked for me. Thanks a lot.


Hi. Actually I think there is a small issue in your command. There must be a space after the wim:1 and the forward slash preceding the LimitAccess.

try this link

you can convert an esd to a wim using dism, as the iso, at least from what I could find, no longer contains a wim

WOW! It worked! I have been messing around searching for an understandable article, and I found this to be the best. Thanks a lot!

How can I provide provide DISM with a location that contains the files it needs to attempt the image repair?
I think I know the malfunctioned files, I just need them to be replaced to the original microsoft version.

This whole discussion is rendered moot if the correct ISOs are not available. I followed the
first reddit link ( and downloaded a 4 GB file (Win10_1511_1_English_x64.iso) which failed, source not found.

So I followed a link here in the discussion (microsoft - suggested by Kevin) and downloaded another 4 GB (Win10_1607_English_x64.iso) which proved to be exactly as useful.

The second reddit link (gist.github) contains hundreds of versions of Windows I don’t need, Ultimate, Single Language, and a bunch of specialised versions, what look like for embedded systems and “China only” legalisation versions… but no Windows 10 Pro.

Seems really odd that MS have this (allegedly) powerful tool called DISM but no way of running it except if you win some kind of lottery. I really, really don’t want to reinstall this PC, its user has just got it running the way he likes it!

Incidentally, the suggested link in the error message (LinkID 243077) might as well have been written in Cyrillic for all the information I managed to get out of it.