Fix: "ms-windows-store:PurgeCaches, The application didn't start."

Well, that is for downloading and installing games directly, but my problem is that it is the store framework that does not work, that is:

  1. the Microsoft Store itself
  2. any System App, as for instance Feedback Hub (it opens, appear and disappear with no error)
  3. any third parties’ app (as Alienware Control Center)
  4. the Search bar of Cortana
  5. the Search bar on Internet Explorer
  6. the Notification Sidebar on right side
  7. the Start Button and tile menu

I temporarily solved the last problem by Open-Shell which provides me also with a good Search bar, but I am missing the rest. I installed a app directly from bundle as a test, but it opens and close suddenly as all the others. Just consider that in the past I reinstalled Windows 10 from scratch: the Store worked fine for one day and then the problem occurred again. If I create another user, the problem occurs for the other user too.

I can confirm without any doubt that the last Microsoft store update broke everything.

I even restored and was able to open up Microsoft store without no issue… but then it auto updated without me creating a restore again and force quit the application and store won’t reopen. All the installed apps for the store work. But the store won’t open.

I have been working on tracking down the problem for the dependencies and was able to manually rewrite a few powershell lines that are customized to what the problem is.

But I don’t fully trust the solution as it might break things for others.

What I’m determining is if we can’t get wreset.exe to work and ms cache to run that nothing will work. Or ever work again.

Edit: I really hate that Microsoft deletes restore points after they restored.

Yes, you are right they should have a way to download and Install a Package from Scratch. It is possible to do it and you can actually Install it from scratch but I think there should be a better way to do it from Microsoft as well. Here is how you can do it if you want to give it a shot: How to download Microsoft Store apps without store?

I messed up with the permission in the WindowsApp folder, and the last command for resetting the permissions worked for me. Thanks.

Thank you so much guys…tried everything to open the store and purge caches but this one worked!

What worked for me was to reset the permissions on the WindowsApps folders with the following in an elevated command:

icacls “C:Program FilesWindowsApps” /reset /t /c /q

The mediafeature pack won’t run

I reset the Windows and the problem still was there. The only solution was formatting… Such a bad experience, Microsoft messed up again.

I would suggest backing up and resetting your PC

We’ve updated Method 1 to address permissions issue.

Thanks brother, I tried EVERYTHING out there and none worked. I don’t know which method worked for me as I did everyone and when I restarted pc, I got my Store back to open.

I wonder why MIcrosoft does not create a Package to reinstall from scratch the Store and default Apps without having to reinstall the whole Windows. There are so many people with my same problem.

I have

Microsoft.Windows.StartMenuExperienceHost_someletters

and

ShellExperienceHost_someletters

somelletrs are the same.

You didn’t mention any of this information before that’s why I was trying to give you possible solutions to diagnose and narrow down to the source of this problem, I work with a Windows optimization team, and the problems that are happening to your computer really similar to the problems everyone else faces when they try debloating their Windows. The exact problem happens when you try to remove dependencies of Cortana/Taskbar or Windows Store from the “SystemApps” folder located on “C:WindowsSystemApps”.

This issue also represents that your Windows shell isn’t loading these apps properly, In our case though the DISM Repair command always fixes these problems however your case is a little more aggressive as you mentioned neither SFC nor DISM fixed the problem you are having. Now even if you somehow managed to recover those Apps packages, I don’t think they will work properly because they won’t be linked to your Windows properly.

These are just my speculations about the problem you are facing, I suggest you head over to this folder “C:WindowsSystemApps” and check if the folders named

“Microsoft.Windows.StartMenuExperienceHost_xxxxxxxxx”
“ShellExperienceHost_xxxxxxxxxx”

Are present or not, If they aren’t present we will try to download the Store app directly and try to Install it. If that doesn’t work I am afraid you might have to reset your Windows but I don’t think even resetting is going to affect this issue if you don’t have the packages that Install the appx apps. Keep me updated!

OK, but the installing of APPX works fine. What I suspect is that there is an issue in some dependencies on .NET or Visual Studio C++ redistributable libraries. Another possibility is a problem with Cortana. In fact the search bar does not work in either the desktop taskbar and Internet Explorer. As well as the Start menu does not work. I am temporarily using Open-Shell, which is providing me most of missing functions. However it does not provide an alternative to the store. A typical error I have in the Event Viewer is

The server Microsoft.WindowsStore_12104.1001.1.0_x64__8wekyb3d8bbwe!App.AppXxxnt3skd41veb34vkvcyva53g0wwk0gg.mca did not register with DCOM within the required timeout.

or

The server Microsoft.Windows.Search_1.14.1.19041_neutral_neutral_cw5n1h2txyewy!CortanaUI.AppXf8r3d8cn5hd71h9jyzah6ak9f3shj2d2.mca did not register with DCOM within the required timeout.

I do not like to make experiment with my PC. That is, I do not like “try and cross your fingers”. I prefer to understand. I am pretty sure all I need to understand is the Event Viewer but it would require a deep skill in Windows internal mechanisms that I have not.

No, you aren’t going to lose anything, sometimes a third-party program stops the Windows Installer service that can cause issues while Uninstalling and Installing the APPX packages properly, this command will just make sure that the service’s parameter is set to default and it actually starts when your Windows is started. There is a long procedure that you can do, opening services.msc and enabling the service manually but I decided to give you just the command to make it a little bit easier for you but if you want to do It manually let me know!

Before I do that, which are the effects? Am I going to loose something or to reset something I might not wish to reset?

That’s a really odd and unfortunate situation, however, there are still some things that we can try. Follow these steps please:-

  1. Search for Command Prompt in your Search bar and click “Run as administrator”.
  2. Now put this following command and press enter.

sc config LicenseManager start= demand

  1. Restart your computer and check to see if the issue persists.

I know that. It does not work. Tried a lot: sfc, dism, new account, store troubleshooter, wsreset, folder ownership, power shell reinstall. No way.

Hey Dejudicibus,

Try this command it will reinstall all the store apps present in your Windows:-

  1. Search for Windows PowerShell in the start menu and click “Run as administrator”.
  2. Type the following command:-

$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + ‘AppxManifest.xml’ ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest

then press enter.
3. Wait for the command to finish then restart your computer.

Check to see if the issue still persists. Keep me updated so that I can assist you further.