Fix: The Dependency Service or Group Failed to Start

Originally published at: Fix: The Dependency Service or Group Failed to Start

A pretty well-known Windows issue, pretty much because of the sheer number of people who were and still continue to be affected by it, is one where the affected user’s access to the internet becomes entirely non-existent and a message that reads “The dependency service or group failed to start” is displayed in their Network…

Been doing this for months finally found your article now sitting waiting for it to work…and OMG it has n it is restored my sound as well. I can never thank you enough

Works great.! Thanks

Worked for me. Thanks!

This worked like a charm, Kevin. Thanks so much, you saved me with this. It was a production server that was giving problems, and this solved the issue with no problems.

Awesome… Thank you so much. After wasting 3 precious hours of my working time I got my hands on your article. And it worked like a charm. Thanks again!

Hi Kevin
Try the above but still cannot resolve the dependency service group failed to start error on my Window Vista Home. Still no Lan and wireless connection.

Man thank you so much! The first attempt was unsuccessful, but the second attempt worked!!! I love you man. Thank you a million tons!!! I was about to request my father for a new laptop but he couldn’t afford. But you saved my laptop.

The article was updated to accommodate a new method, check it out.

Okay, but what do you do if you get that error when you try to open a Command prompt? This is happening on a SharePoint WFE server, the O/S is Windows Server 2012.

didnt work for me :frowning:

you’re great. …

I did this and it did not work. BUT immediately afterwards I opened msconfig and went to the services tab and selected windows event log & windows event collector. Both were not selected. I KNOW there was something wrong with permissions. Obviously, they have to be working together. THANKS SO MUCH!

you need to check permissions, or create a new admin account and test.

I am getting an error that says - ‘system error 1379 has occurred’ The specified local group already exists.

My network and sharing centre still shows the following message - ‘The dependency service or group failed to start’

Please help. I tried all the available solutions. I am running windows10

Dear Kevin,
Thanks a ton for this solution. I spent more than 3 hours trying to fix this issue which cropped up after I fixed a Bluetooth error post an update on windows 10.
This worked like a charm. Great work :slight_smile:

Didn’t work, still able to connect, but unable to see the connections on the network and sharing part. I am also unable to see my network(S). Please help me? And if there is no answer, i’ll ask my father. If he can’t fix it, well a fresh reinstall of windows, and so forth. hopefully that’ll work. probably not…


Brilliant! Thank you :-{)

Actually lifesaving. I was ripping my hair out after I upgraded my ram.

Thanks for the solution. Appreciate it.