Fix: Your Credentials Did not Work in Remote Desktop

Originally published at: Fix: Your Credentials Did not Work in Remote Desktop

The error message ‘Your credentials did not work’ appears when you fail to connect to the remote system using Remote Desktop connection. This error is often caused by Windows policies that prevent incoming RDP connections, or simply your system’s username. Dealing with this particular error can be infuriating as the fault isn’t in the credentials…

Just adding another “+1” – this worked for me as well after 4 hours of time wasted. I usually used my PIN to log onto the remote machine. I logged out then logged back in using my Microsoft account password. I can now use Remote Desktop to log onto that machine. Whew!

This worked for me too

Pure genius on this one! Got it!

You are a god!! Been struggling with this on a brand-new Windows 11 install for an hour now, and then finally came across your post. I had only ever logged into the new PC using a PIN, and so I could not remote-desktop in, just as you said. But when I did what you suggested and logged into the new PC locally at least ONCE using my password instead of my PIN, then I could finally remote-desktop in as well! Thanks so much!!!

It seems like Windows (11) does require a local password to log on via RDP. A few people have discussed this option already, but I would like to contribute another solution in case you can neither sign in with a local password nor create one (as was my case). The option to add a password, as shown above in solution 5 simply did not exist for me; my account is an online account.

This solution did not require any of the above steps, nor did it require me to turn Windows Hello (or the under Sol. 5 mentioned option) off.

If you are on Win 11 with Hello and 2FA, nothing else worked so far, and you can’t set or use a local Password, you might want to try this:
Sign out > inhibit Hello from signing you in, and click ‘sign-in options’ > click on ‘I forgot my pin’ > log in with your Microsoft account (and therefore your account Password) > approve the sign in request, in case you have 2FA > confirm that ‘you are sure’ to reset your PIN (you can set the same PIN again) > reset the PIN.

Thats it, all Windows needed was for you to sign in once with your account password. At least, this is the solution that worked for me.

mstsc.exe is not reading from Windows Credential Manager anymore. Just use mobaXterm instead.

Now I think the underlying issue is that one has to sign in locally with a password at least once. Only after doing this, can one connect with RDP using a password. That is in line with Jim’s comment above. I was initially signing in locally with my PIN only, and for some reason that isn’t good enough.

Looked everywhere this is the answer I was looking for. You can logout, Change Sign-in options, revert to password and enter your MS credentials there. Log in and it will work. Thought I was losing my mind!

More info here:

How does that go with published remote apps?
yeah, thought so.

This guy is a legend… and it’s such a silly bug too.
thanks a ton man!

I’ve been googling for a while and I’m glad I’ve found this answer before trying anything else! It didn’t make sense to me that I would have to do everything in these articles when I could log into another account on my target PC (although it probably could’ve been the case, if settings were only applied per user). Thanks!

Thank you for sharing your solution it will be added to the article shortly.

Thank you for sharing your solution it will be added to the article shortly.

None of the above or below mentioned solutions worked for me. I found out I had to enable this:
start-run gpedit.msc
computer cfg - admin templates - windows components - remote desktop services - remote desktop session host - security - Require use of specific security layer for remote (RDP) connections - ENABLE - select layer RDP. Apply, ok, bang, connected. You’re welcome.

This was my fix too. Only took about 8 hours to figure it out

Thank you Jim - this is exactly what I needed!!! Awesome Job!


What eventually worked for me was under Sign-in options, I turned off “Require Windows Hello sign-in for Microsoft accounts” and enabled password sign-in.