How To Fix Error 0xc00000e9 on Windows 7, 8 and 10

Originally published at: How To Fix Error 0xc00000e9 on Windows 7, 8 and 10

Error 0xc00000e9 is usually caused by a failing or a bad hard drive. That will be the final verdict on this if none of the possible solutions provided below work. If, in case the hard drive has failed, you can send it to a recovery company to recover your data. It’s a hassling process, but…

Thank you guys for this post, Kevin Arrows this post is great,and it helped solve the problem, so all I did was put the windows CD in and chose the CD-ROM from the boot menu and it worked, it started to install windows as new. I tried all sort of methods but none worked, after looking at your article it did help a lot. so thank you very much you guys are geniuses. G.

Great app! At least I can see the HDD on the PC that got knocked down while running, instead of getting that oh-so-descriptive MS error message. One suggestion - tell users to use the ISO image that comes with the program instead of finding the one on the PC they are constructing the HBCD source on.
I did it that way using Rufus to create a bootable USB and was wondering why I couldn’t see the HBCD folder… it worked great once I chose the HBCD.OSI as the source image.

how can i burn hiren into my usb please help :frowning: i’m having difficulties in magic iso. i cant find the word that it will burn it into my usb. :frowning:

That’s a very general response. Please be specific.

Tried all methods, nothing works. What do i do? Please help

I needed to use a different image on the new drive and that fixed it.

I am glad to have found this guide. I wasnt able to fix the issue but i guess i am pointed to in the right direction.

Thank you - I was able to fix the issue with method 1

i have a error, it says
Load error: no DPMI - Get csdpmi*

I was having some issues in downloading from their site, so I used torrent. It was of exact same size as that on their website. Should I download it again from their site?

Hi Kevin,

Thanks for the guidance. I’m having a little problem.
When I choose HDAT2 4.53 (Test/Repair of Bad Sectors), it shows as

Load error: no DPMI - Get cgdpmi*

I googled it but could not find the solution so here I am to cause you trouble. Please help

Thanks in advance.

What’s the error?


The old lad is glad to have found your site. Hiren fixed the issue, it appears that our disk had a lot of bad sectors.

download hiren and burn using rufus.


is there any free application i can use to burn or to put hiren in my usb?

It should be less then 5 minutes.

Thank you for this thorough explanation. Quick question though; how long should it approximately take to launch the Dos Programs? My screen just says ‘Booting Dos Programs’ with a blinking underscore on the left side. Thanks.