SOLVED: Windows 10 Sleeps After 1-4 Minutes of Inactivity

Originally published at: SOLVED: Windows 10 Sleeps After 1-4 Minutes of Inactivity

After upgrading from an older version of the Windows Operating System to Windows 10, or even after upgrading from an older build of Windows 10 to a newer one, quite a few users start experiencing a variety of problems, chief among them being their computer going to sleep after 1-4 minutes of inactivity. For some…

Quite old article but still very relevant. It’s very strange, earlier today my Windows 10 PC suddenly started going into suspend after just 1 minute of inactivity. Prior to this (I mean at least 1 week) I haven’t messed with any power plan settings, haven’t updated any drivers nor updated or installed any software, Windows Update is totally disabled (registry, group policy and hosts file), and I haven’t changed or added any hardware, so I have no idea what could have triggered this.

I went into the power plan screen and nothing was changed, my power plan was still configured to suspend the PC after 20 minutes of inactivity (which is what I normally use). I took a look at the registry key mentioned in Solution 2 and the “Attribute” value was already set to 2.

Anyways, looks like I have fixed the issue by just going into power plan settings, and changing the suspend time to a different value (15 minutes) and then setting it back to 20 minutes again. That “attribute” registry value hasn’t changed, it’s still 2. So I don’t think solution 2 actually does anything, at least not in my Windows 10 build (I’m on Windows 10 1909 build 18362.239 - very old version but it works wonderfully and I have pretty much zero issues with it, other than this one that is)

tried them all… my computer still “looks for me” and if i move, sneeze, step away, it goes into sleep mode and i have to sign in again and again and again… damn MS

The article was updated to include more methods

None of these options work. I go into the Power Settings and switch everything to NEVER then when I turn off my computer after working on it and then turn it back on at a later time, the Power Settings revert back to “Turn off Display Plugged in” 15 minutes and everything else is NEVER. Every single time. Even if I change the 15 minutes to 1 hour or higher, after turning off my computer and coming back to it later the option reverts to 15 minutes again.

I have checked for viruses and malware and other problems and cannot seem to fix this issue. Windows 10 is the worst OS I have ever used and if I could go to Windows Me, which is far superior to 10, I would. I would even go to Vista or 98 than have this garbage OS on my system. I am tired of my PERSONAL COMPUTER (PC) being held hostage by Microsucks horrible software. It’s been 2 years since you all have responded and STILL it is not fixed and they have no plans to fix it. Just take our money, spy on us with your least secure OS and forget what we all have to say. That is Microsucks motto.

I just tried #2 and I think it works (I’ll report back if it doesn’t).
You have an amazing balance of clear detailed steps without being overly detailed.

Thank you very much.


Kevin, you are champ. I have not seen such comprehensive problem solution for a very long time. Well done. thanks for sharing

Another vote for Method 2. I had tried everything else first, being wary of editing the register; but it worked perfectly.

Solution 2 worked for me. Thanks Kevin.

I turned it off and then logged into my laptop and let it sit, still turned off display after 3-5 minutes.

Agreed, this is a HUGE DAMNED W10 defect that Msoft MUST fix. It is crazy to expect the average user to have to do this. Best is to set it to 0, then it never uses this option because it is impossible to do NOTHING when you start and the other sleep settings work as they should then.


I’ve had to use method 2 on a couple computers. It’s very annoying to have to go this far to stop the computer from sleeping in 2 minutes. Most newbies will never get this far. I can’t recommend Windows 10 to those who need this fix but will never be able to do it themselves.

that worked perfectly thank you

Option number 2 finally worked for me. Can’t believe one has to go to this length to change the log out timer from 2 minutes! to something reasonable. So it’s a two step process, first change the registry setting (watch video) and then go into your power options which will now have a new option to alter the “system unattended sleep timeout.”

Option 2 worked for me. I rarely take the time to add comments on anything I read online but feel compelled to share my appreciation for this post as I’ve been trying to fix this issue for a long time and have tried everything but this. Thank you Kevin!

I just used Option 2 and it seems to have worked.

Hey Kevin! You’re a life saver. This annoying problem was present in my new Acer Nitro 5AN515-51 and after they replaced my unit for a second time, I was starting to think that I had really got a lemon and was about to ask for my money back. I’m not really sure what worked here, since I had tried fixes 1 and 2 before and when those two didn’t do anything I tried number 3. I also selected 6000 (six thousand) minutes as the time needed for my laptop to go to sleep. I often leave it working on something and I hated when I came back after a couple of minutes from the kitchen and it had stopped doing what it was supposed to do because of this stupid error on Windows. Thanks mate. Cheers!

Option #2 did it for me. THANK YOU. You’re Awesome!

Option 3 worked for me. It was already set for NONE, and the timer was set for 1 minute. changing timer solved the problem. Thank You!