Windows Won't Use Full RAM? Try these Fixes

Did you not read my post? I said I just upgraded to Win 10 64 bit to explicitly use all 96 gigs of ram. I have both Win 10 and Win10 pro. So you’re telling me that Win 10 pro won’t let me utilize all or most of the ram for performance? I was told the only win 10 can see all the ram in a system, up to 2 terabytes. System info page still says 24 gigs installed. Where’s my other 72 gigs?

You downloaded 32Bit Windows 10 or 64 bit?

Ok guys, I have one for you. I’m running an Asus X58 Sabertooth MB with 96gbs of ram. Yes, 96 gbs of ram. That’s 6 sticks at 16 gb/slot. Now I upgraded to Win 10 from Win 7 so I could utilize all 96 gbs for online gaming. The “about” page, mentioned above, says I only have 24gbs installed. All the suggestions here changed nothing on that page. In fact, I was warned not to zero out the page files as windows should keep a minimum of 800mb on hand to report errors. With previous OS’s, setting the page file to 2 1/2 of the total memory on the MB was sufficient for efficient OS operations.
How do I get Win 10 to use all the ram, or is the 24gbs what it needs and the rest is what I use when gaming?

Keep me updated!

Please follow these steps:-

  1. Press and hold the Windows key then press the “R” key to open the Run program.
  2. Now type “DxDiag” and press enter.
  3. It should open the Direct X Diagnostics Tool.
  4. Take screenshot and reply back to me with the screenshot.

Hey Adelin Marin,

Try Updating your BIOS, If that doesn’t work for you. Try swapping the order of your RAMs to check to see if that brings any better results.

Please open your Task Manager head over to the “Performance” tab and provide me a screenshot.

i have installed 16 gigs ram: 2x8. but the system shows only 8 gig ram installed in window 10.

These solutions did not work for me. I’ve been playing about with an old HP laptop out of interest, it has 4Gb installed but only 2.9Gb available. I have some interesting observations about the problem. Normally I see 1.1 Gb of hardware reserved RAM. If I remove a 2Gb stick the HW reserved drops to 142Mb. If I replace it and remove the other one I still see only 142Mb of HW reserved. I wanted to verify where this reservation is coming from, i.e. BIOS or Windows 10. So I booted the laptop up to SLAX Linux and ran the free -h command to view available memory. Guess what? 2.9Gb available, in Linux, the same as in Windows. It looks like windows plays no part in the HW reservation, in my case anyway

Probably because your CPU wasn’t seated properly? i think this might have been the issue. Was it seated properly before?

Okay, skip that and go for the Bios update and RAM inspection. Are you sure that your RAM sticks are working correctly?

Maybe the RAM sticks are at fault? have u tried them one by one? also try them a single one in different slots to make sure that the slots aren’t fried.

Sadly, did not help at all.

How are your rams installed? are there 4 slots? if so, install them with space in between them. Like install RAM 1 in the first slot and leave the second adjacent one empty. Then install RAM 2 in the third one and leave the next one empty.

This fix made my usable ram go down i have 8 gb of ram installed and in general my pc just sucks i think my solution is just buy a new computer and throw linux on it cuz windows 10 is overpriced garbage that forces you to have preinstalled programs restricted from uninstalation that do nothing but use up ram disk space and prossesing.

Might be an issue with the RAM or the Motherboard

What error do you encounter while updating?

Maybe the Motherboard is faulty, have you tried it in another motherboard? in some cases, the motherboard doesn’t use the RAM although it is available.

in my case, my laptop asus x555d always lose 1gb of whatever total ram. standard is 4gb onboard installed and shows 3gb usable. then i tried add 2gb more (4+2), shows 5gb usable. and i tried add 4gb (4+4), so it shows 7gb usable. does the radeon graphic take the 1gig or something? its radeon R6 M340X 2GB…shouldnt it have its own memory? even if it is the one taking my ram allocation, why only 1gb not 2gb as specified? weird.

ehm, after reading up somewhere else ive come to conclusion that 1gig highly likely reserved for the other graphic since my laptop uses radeon dual graphic. initially i dont really mind 7/8gb. i just want to know why, so that i dont do something unnecessary like forcing 8gb to be usable where it can backfire instead

option 1 worked for me.